15

I'm using CUPS to print on an enterprise network. The job gets submitted fine, but I need to submit it as another username. Now I'm jon but I need to send it as say jonallard.

On the command line, one could print as such

lp -U jonallard -d printer1 file.ext

How do I customize the username part when using the GUI printing dialogs and the Printing system settings?

It is possible that it isn't, in fact, possible to add this username to the Ubuntu print config. If so, where should I ask for an improvement?

7

According to the man page https://www.cups.org/doc/man-client.conf.html, a User directive could be placed in /etc/cups/client.conf or ~/.cups/client.conf

However, this didn't work for me in Kubuntu Trusty. What worked, was to export the CUPS_USER environment variable by adding the following line in ~/.profile:

export CUPS_USER=vangelis

Needless to say (but I say), that you need to change vangelis to the username you would like to use.

You also need to restart your system so that the changes take effect in the desktop environment!

This information can be found at CUPS 1.6b1 release notes here: https://www.cups.org/blog.html (search for CUPS_USER)

4

The issue has been reported as a bug (856776) and is now on the wishlist.

  • 2
    yep, "wishlist" doesn't really help those of us stuck with an office full of Ubuntu PCs that now can't print. sigh – artfulrobot Dec 18 '12 at 11:19
  • "Ubuntu: We don't care." – jonallard Nov 30 '13 at 2:12
3

This works for our system. Tested in Ubuntu 10.04 - 14.04, Linux Mint Print server Canon Uniflow, secure printing

First, stop cups

sudo service cups stop

Then edit the file /etc/cups/printers.conf and add your username to the DeviceURI like this:

DeviceURI lpd://myusername@server.my.domain/our_printqueue

Now start cups again

sudo service cups start

However, be aware that this setting effects all users on this machine.

  • Since it affects all users on the same machine, just use your computer's hostname instead .... still recognisable ! – MikeW Nov 10 '16 at 10:40
  • This works for me for LPD print queues but unfortunately not for IPP print queues (using Xubuntu 14.04, CUPS 1.7.2). – bmaupin Feb 16 '17 at 13:45
1

You could use the username in the IPP URI when adding the printer queue, see this document for details:

http://www.cups.org/documentation.php/network.html

Otherwise I can see no options in cups or gnome print dialogs to help you select a username for printing.

  • The print settings don't allow entering a username as part of the IPP URI when configuring. – jonallard Sep 17 '11 at 9:03
  • You can add the username to the URI when adding the printer right? – Martin Owens -doctormo- Sep 17 '11 at 10:37
  • No. (is too short) – jonallard Sep 17 '11 at 18:20
  • 1
    Then this is a bug and should be reported under the gnome printer settings project in launchpad. – Martin Owens -doctormo- Sep 22 '11 at 12:19
  • This didn't work for me for an IPP URI, although it did work for an LPD URI. I noticed the documentation (cups.org/doc/network.html) doesn't mention username as part of the IPP URI, but I'm not sure if that's significant or not. – bmaupin Feb 15 '17 at 17:52
1

Always a bit late re. the original question, but the solution that worked for me in 2018 (and on Debian, but I assume the procedure is similar) is to edit, as root, the file /etc/cups/printers.conf, and to add the directive User official-user-from-printer's-pov in the printer part. Too bad I couldn't find it on the shiny cups admin interface...

  • When I do that (using Kubuntu 16.04) cups just overwrites printers.conf with a version without the User directive, when I restart cups. – Supernormal Apr 13 '18 at 8:28
  • Documentation says that printers.conf is not intended to be edited or managed manually link – Igor Rodriguez Sep 19 '18 at 13:12
  • @Supernormal you must stop cups service first – qwr Mar 28 at 19:19
0

I had the same problem as you, and I found a way to do this on my machine. On (X)ubuntu 14.04, I had to set the "Job/Billing Info" value in the print menu. Then, the print arrived correctly at my printer. I attached a screenshot for your reference. No other settings were necessary (apart from setting up the printer initially using its URI).enter image description here

  • 1
    Unfortunately some applications (e.g. LibreOffice) use their own print dialog that doesn't have this option... – bmaupin Feb 15 '17 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.