I am trying to dual-boot Ubuntu 14.04.2 alongside Windows 8.1. I get this error after I configure the "root", "home" and "swap" partitions. I am following this guide.

Here is a picture of the error :- error message

I am pretty new to all of this. Can you help me?

  • This is solution to my problem, i am also facing same issue. I am looking what are the next steps. I am already hacving windows 10 as my primary OS. And was looking to dual boot with Ubuntu for learning linux – Atul Darne May 24 at 18:31

If Windows 8 is pre-installed it is booting in UEFI mode and requires gpt partitioning.

But the error you are getting is because you are installing BIOS boot mode on a gpt partitioned drive. If you really want BIOS boot for Ubuntu then you need a tiny 1 or 2MB unformatted partition with the bios_grub flag in gparted. If you use gdisk to create partition it is code ef02. It actually is a very long GUID that is assigned with these short flags or codes.

But you probably do not want Ubuntu in BIOS boot and Windows in UEFI boot. You may have to go into UEFI boot menu and turn on/off UEFI or CSM/BIOS each time you reboot into the other system. Much better to install Ubuntu in UEFI boot mode.

How you boot install media is how it installs. Your UEFI boot menu for the Ubuntu installer with have two entries. One will say UEFI and name of flash drive and the other just the name of flash drive which then is BIOS boot.

Shows install with screen shots. Both BIOS purple accessibility screen & UEFI black grub menu screen


Also shows Windows 8 screens

Installing Ubuntu Alongside a Pre-Installed Windows with UEFI

UEFI install,windows 8 with Something Else screen shots


Linux on UEFI: A Quick Installation Guide


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.