3

edit: turns out my keyboard was disconnect/reconnecting. KDE is supposed to handle that, but it isn't. reported as https://bugs.kde.org/show_bug.cgi?id=346336

I'm using Kubuntu 15.04 (kde 5.2.2-0ubuntu1). In System Settings -> Input Devices -> Keyboard -> Advanced, I have "Caps Lock -> Make Caps Lock an additional Ctrl" enabled (like any sane person that uses emacslike keybindinds in anything).

This worked fine, exactly like setxkbmap -option ctrl:nocaps, except that it sometimes goes back to the default layout. I didn't log out, suspend, plug in any USB devices, or do anything that would explain this. The settings GUI still has the box checked. Unchecking/rechecking and clicking "apply" enables it again.

Is this normal, or a known bug? Am I doing something wrong? Should / can I tell KDE to leave my input settings the hell alone and just put setxkbmap -option ctrl:nocaps in my session startup somewhere?

Even after using setxkbmap manually, and not touching KDE's settings, the keyboard stuff still gets reset sometimes. Repeat rate is also affected. (The delay gets set to 2.5x longer than I like, 660ms. So I have to xset r rate 250 35 as well as setxkbmap.)

I even unset the keybind for "switch keyboard layout", but it still happens maybe once per 3 hours. I haven't detected a pattern yet in what I'm doing.

I've always used super-lightweight window managers until now, like fluxbox, but I was starting to feel the need for more powerful alt-tabbing to manage my terminals and web browser. It's great so far, much nicer than Unity with it's fairly-bad focus-follows-mouse.

Old cruft in /etc or my home directory is not a possibility: I did a fresh install of Kubuntu, and moved aside all my dotfiles in my home directory before logging in to KDE for the first time. (And then cherry-picked a few, like .bash*, .less*, but not .kde, .config, .local, or .cache). Cruft buildup from 8 years of ubuntu dist-upgrades was really starting to pile up, and with 15.04 switching to systemd, I figured it was time to get a fresh /etc.

4
  • Experiencing the same problem in Kubuntu 16.04. I have used 15.04 before on other machine without problem. The switching back to default only happens after screen lock, but not always. – Jan Brezina Oct 18 '16 at 15:52
  • @JanBrezina: I don't have the problem on 15.10. I still haven't got around to upgrading to 16.04 :/ – Peter Cordes Oct 18 '16 at 18:50
  • @PeterCordes Did you ever find a solution to this? – wizonesolutions Aug 16 '19 at 13:06
  • @wizonesolutions: As I said in the first line, part of the cause was that settings were reapplied when disconnecting / reconnecting a keyboard. It's not a problem on my current Arch Linux desktop with KDE. – Peter Cordes Aug 16 '19 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.