3

I have monodevelop 5.7 installed on my computer with ubuntu 14.10, but when I tried run it from launcher and from the command

~$ monodevelop

they didn't work.

But when I used the command

~$ sudo monodevelop

it worked ok, monodevelop started.

How can I run monodevelop from launcher and command line without using sudo?

Thanks a lot for help.

  • What happens if you don't use sudo? What error message do you get? – Jos Apr 17 '15 at 13:24
  • Nothing happened. When I typed monodevelop without sudo, a while later the terminal return normal state (I mean ~$). – Martin Nguyen Apr 17 '15 at 13:30
  • locate the executable using whereis and use chmod to change its permissions. – We are Borg Apr 17 '15 at 14:35
  • You could try making a .desktop file that will run the program as sudo. – TheWanderer Apr 17 '15 at 15:13
  • @Zacharee1 Quote from above: "How can I run monodevelop from launcher and command line without using sudo?" - By the way, you should not run GUI applications with sudo on Ubuntu, but with gksudo or gksu. And it is recommended to use any variant of sudo as rarely as possible and only when it is unavoidable. – Byte Commander Apr 17 '15 at 15:15
0

First of all look for permission-related errors with: strace monodevelop.

If you found it, change the permissions to that files/directories to match your user. It also helps if you delete every monodevelop-related directories from userspace.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.