The issue is to upgrade a Ubuntu system mounted with an encrypted home (on a seperated partition) which then cannot be decrypted/mounted with the exact same passphrase on a new fresh installed Ubuntu. This question has already been answered but "solved" (?) in a "non-deterministic" way in 602360/345970. I cannot afford keeping reinstalling Ubuntu again and again...

I currently have a Ubuntu 12.04 that I cannot upgrade (via do-release-upgrade) due to package errors. Hence, I decided to make a fresh install of latest LTS Ubuntu 14.04. The system / directory (~50GB) is mounted on sda6 and yet the encrypted home /home is on sda7 (~145GB). I formatted and installed the new Ubuntu on sda6 and specified sda7 to be considered as a mount-point for /home.

After the install asked for a login/password (which I entered as the exact same as previous installs), I tried to log in. However, there appears that Ubuntu cannot decrypt/mount my data and shows the following

Signature not found in user keyring Perhaps try the interactive 'ecryptfs-mount-private'

Morevoer, when I try ecryptfs-mount-private, it asks for the login passphrase which I correctly entered for a dozen times but an error appears claiming that the password is incorrect. I rolled back to Ubuntu 12.04 with a partition backup and checked again that the password was indeed correct.

Hereafter, I discuss related issues that are not relevant to this one or left unanswered:

  • 115497/345970: ecryptfs-mount-private is not an appropriate solution. Even if, my data is correctly decrypted, it requires me to allocate twice + 3/5 of the current home directory space disk to first decrypt and copy and then re-encrypt.
  • 129906/345970: Issue not answered but possibly the same (up to operating system version)
  • 182078/345970: Not related to the question of re-installing an operating system.
  • 286828/345970: Same issue but remained unaswered.
  • 341302/345970: My login passphrase is the same as the UNIX user password. Different issue.
  • 476037/345970: I'm not using LVM. In any case, that question was left unanswered.
  • 485625/345970: I'm not using different user login names.
  • 584656/345970: Same issue. No appropriate answer.
  • 602360/345970: As said earlier, "solved" in a random/non-deterministic way, by re-installing again and again Ubuntu until reaching a match.

It is really simpler than you think. All you have to do is that when installing the Ubuntu, you will see a page in the installation wizard called user settings. There you will fill up your system password and usernames. So down there you can see a check box says Encrypt my Home folder also All you have to do is that to check mark it and proceed as usual. It is easy to do.

  • I already did this. I repeated the procedure into a virtual machine according to the following protocol: – Hai Nguyen Van Apr 18 '15 at 16:32
  • 1. Install Ubuntu 12.04 with / (partition p1) and /home (partition p2) on seperated partitions with main user named jackpot 2. Reboot then encrypt jackpot's home with ecryptfs-migrate-home with the same password as encryption passphrase 3. Install Ubuntu 14.04 on partition p1 and specifying p2 as the /home mount point (as shown here) – Hai Nguyen Van Apr 18 '15 at 16:41
  • 4. Filled up with exact same credentials during installation. The box for encryption was grayed and checked/ticked as default (as it detected it was using an encrypted home directory) (as shown here) 5. Rebooted and attempted to log in with credentials in question. This led to the same errors (as shown here). – Hai Nguyen Van Apr 18 '15 at 16:41
  • If it is not working, then it might be the problem with the compatibility of the ubuntu version you are trying to install in. Or may be the problem of your partition too. So try changing the version of ubuntu or the partition in which you install it. – Nived Kannada Apr 19 '15 at 12:33
  • 1
    Can you confirm to me that you did not encrypt the whole /home partition ? But only your home directory itself via ecryptfs-migrate-home ? – Hai Nguyen Van May 4 '15 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.