I used to be able to switch to Nvidia by going to software sources. Now when I click the driver for my graphics card it downloads, turns green and it looks like its using the correct driver but when I go to system details it says its using my Intel graphics. The performance is accordingly average... But I have gfx card with 2G of dedicated memory! Is there a way I can do this? Possibly something in grub? Or even better: graphics card switching without need for reboot? Something like: https://gfx.io/?

If you have nvidia prime installed just go to nvidia x server settings and choose it in prime profile (you need to relog to apply the changes). Nvidia prime

To install prime:

First make sure bumblebee not installed! Or just remove it:

sudo apt-get purge bumblebee*

Install:

sudo apt-get install nvidia-prime

You can also install prime-indicator for easier switching. Prime indicator

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install prime-indicator

If you prefer to use bumblebee/have it installed you have to run the application with a command to use the video card (advantage: you don't need to relog).

optirun <program-name>

To install bumblebee make sure you remove prime! More info: https://wiki.ubuntu.com/Bumblebee

  • for some reason this happens: link – Eliáš Bauer Apr 17 '15 at 13:15
  • 1
    I recommend you to remove all and re-install: sudo apt-get purge bumblebee* nvidia* Then install: sudo apt-get install nvidia-331 nvidia-settings nvidia-prime – guyromb Apr 17 '15 at 13:55
  • Also go to settings -> Software & Updates -> Additonal drivers -> Choose "using nvidia binary driver ... (prop, tested)" – guyromb Apr 17 '15 at 13:58
  • I reinstalled exactly as you said and this is a screenshot of my "additional drivers" list imgur.com/e64JFXN but i still get that blank error :/ – Eliáš Bauer Apr 17 '15 at 15:08
  • I found this but not sure which solution is best for me... Any advice? Or should i try them all? askubuntu.com/questions/450154/… – Eliáš Bauer Apr 17 '15 at 15:20

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.