I have an embedded board with Ubuntu 12.04 LTS GNOME 3.4.1. With this board I am using LCD display 800x480 and HID resistive touchscreen. Everything works fine but I have a problem with some dialog windows - for example "System settings" - this box is bigger than my screen. It means that I can't see the lower part of this dialog box (Apply, save button and so on).

I tried this: How can I resize the System Settings window?

It looks cool but without success :(

Then I tried this:

In xorg.conf (in /etc/X11) I edited this:

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"
Virtual 1024 768

then I ran xrandr -s 1024x768 and it came back with the following error -

Size 1024x768 not found in available modes

I also tried:

 xrandr --output default --fb 1024x768 --panning 1024x768

without success.

UPDATE: I found this (last post): How to detect and configure an output with xrandr?

so I ran this commnad to get the modeline of the monitor:

gtf 1024 768 60

The output of this command is:

Modeline "1024x768_60.00"  .. some numbers .. -HSync +Vsync

After that I added new mode, add mode and change resolution:

xrandr --newmode "1024x768_60.00"  .. some numbers ..  -HSync +Vsync
xrandr --addmode default 1024x768_60.00
xrandr --output default --mode 1024x768_60.00

and it did nothing. No change on the screen.

I also tried this after that (suggested by Ken Mollerup below):

xrandr --output default --rate 60 --mode 800x480 --fb 1024x768 --panning 1024x768

But that also did not work

  • It is possible, I have resently seen it on my system, I vas trying to use 2finger gestures to zoom and pan in GoogleMaps, when my screen 1920x1080 syddently was a viewport into a much larger screen. Try This setting instead: $ xrandr --output VGA --rate 60 --mode 800x480 --fb 1024x768 --panning 1024x768 found in our wiki here: wiki.ubuntu.com/X/Config/Resolution – Ken Mollerup Apr 17 '15 at 12:32
  • Thanks, I tried it, but I get this error: screen cannont be larger than 800x480. I run this command: xrandr --output default --rate 60 --mode 800x480 --fb 1024x768 --panning 1024x768 – Maros Apr 17 '15 at 13:01
  • What videocard do you have? – Ken Mollerup Apr 17 '15 at 13:13
  • I have no videocard :) I have an embedded board with iMX6 ARM and my LCD display is connected via RGB interface (the driver for this interface is included in kernel). After I run "xrandr -q" commnad I can see: xrandr: Failed to get size of gamma for output default Screen 0: minimum 800x400, current 800x480, maximum 800x480 default connected 800x480+0+0 0mm x 0mm – Maros Apr 17 '15 at 13:34
  • I was just wondering standard low VGA resolutions are 600x480 and 800X600, so we should be able to get 800X600! Maybe we need to tell the Grub loader? – Ken Mollerup Apr 17 '15 at 16:32

I had this problem with Ubuntu 12.04 on my netbook (1024x600 screen). I "solved it" (really worked around it) by making sure that all windows start out maximized. This helps, because maximized windows that are bigger than the screen, show the scroll bars. And, if you can access the scroll bars, you can thereby reach all parts of the window.

To do this, install CompizConfig Settings Manager, (which is kind of a scary program), and in Windows Rules, set the Maximized rule to class=. This forces all new windows to come up maximized.

I didn't figure this out myself... I think this may be where I got the answer from. I am not sure why I used the 4th answer there - I was very new to Ubuntu then! But, perhaps just knowing that starting all windows maximized is a workaround can help you google up more info if you need it.

  • Thanks! It seems to be like a cool solution, I will try it and let you know! Right now I do not have my embedded board here – Maros Apr 18 '15 at 9:38
  • In my desktop Ubuntu 12.04 Unity it works well, but in Ubuntu 12.04 GNOME 3.4.1 no :( For example: I tried maximize xterm, or run chromium browser in fullscreen mode and nothing. So I think that CompizConfig does not work... I also check GNOME Compatibility - without success :( – Maros Apr 19 '15 at 12:35
  • Argh! Sorry it didn't help. – Organic Marble Apr 19 '15 at 14:23
  • And do you know why? Is there some conflict between gnome and compiz? Why in unity it works and here not? – Maros Apr 19 '15 at 14:47
  • Sorry, I have never used gnome and know nothing about it. Maybe there is a way in gnome to get the windows to start up maximized? – Organic Marble Apr 19 '15 at 14:48

I tried almost everything and still without success. But I discovered that my system uses Unity 2D. In the Unity 2D compiz does not work. It could discovered with this command:

ps ax | grep compiz


4166 pts/0 S+ 0:00 grep --color=auto compiz

It means, that compiz does not run. If compiz runs, it will be like this:

1401 ? Sl 2:29 compiz
4166 pts/0 S+ 0:00 grep --color=auto compiz

In Unity 2D uses Metacity and this can be edited in gconf-editor. More information is here: How do I configure Unity 2D?

ps ax | grep metacity
1401 ? Sl 2:29 metacity
4166 pts/0 S+ 0:00 grep --color=auto metacity

So now I have to set fullscreen rule (or maximize) only for "system settings" window. Right now I do not how.. I do not want to use any keyboard and android is not good choice for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.