I'm running ubuntu 14.04. I cannot use software center to install anything, even a local deb package so I have to rely on Terminal.
Recently I was trying to install
mysql-server which generated error which I could pin-point was the required version of libstdc++6 . My system had 4.8.x while mysql 5.6 required >=4.9.
Trying the usual upgrading process and unsuccessful, I consulted my sys admin, who tried installing the 4.9 package manually(using a local .deb package), which failed as well citing unmet dependencies.
At present, what I have is a system with error saying no new software can be installed.
sudo apt-get install -f gives following output:
Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... failed. The following packages have unmet dependencies: libstdc++6 : Depends: gcc-4.9-base (= 4.9.2-10) but 4.9.1-0ubuntu1 is installed libstdc++6:i386 : Depends: gcc-4.9-base:i386 (= 4.9.2-10) but 4.9.1-0ubuntu1 is installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
I checked for held packages using
dpkg -l | grep ^h dpkg -l | grep hold
Also tried to find the broken package, if any but the file
/var/log/dist-upgrade/apt.log doesn't exist.
So, what should/can I do now.