1

So my laptop is dual booted with Windows 10 and Ubuntu 14.04 on a 240GB SSD (aftermarket). It has worked fine for months. I never use the Windows partition unless I have to, and haven't used it for weeks. Today I was working in Ubuntu, when my status bar at the top seemed to be shifted over to the right and I was unable to click anything. The computer appeared to be freezing up so I held the power button to shut down. Upon startup, I got the "No Operating System Found" message.

I popped in the Ubuntu 14.04 Live DVD and booted into the tryout mode in order to run boot repair. I went through the process of installing boot repair and when I run it I don't get an option to do the "Recommended Repair". The button is nonexistant. The only option it gives me is the boot report, which gave me this report:

http://paste.ubuntu.com/10835862/

I looked over it quickly and see that no boot loader is installed, no partitions were found, and this message at the bottom:

The default repair of the Boot-Repair utility would not act on the MBR. Additional repair would be performed: repair-filesystems

I attempted to reinstall GRUB2, so I ran gparted to see my partitions. Only two show up:

  • /dev/sda1, FileSystem:unknown, Size: 8.02GB
  • unallocated, Size: 14.35GB

I'm guessing this is reading from the smaller onboard SSD intended for the operating system (originally meant to be used for Windows speed boot, or whatever it's called).

It appears that it can't find the 220GB SSD?

I tried mounting the partition (the only partition available) I get this:

mount: block device /dev/sda1 is write-protected, mounting read-only NTFS signature is missing. Failed to mount '/dev/sda1': Invalid argument The device '/dev/sda1' doesn't seem to have a valid NTFS. Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

I have a really bad feeling about all of this, and I have no idea what has gone wrong. Any Ideas? Thank you all in advance!

0
0

I'm pretty sure my SSD crashed, as it doesn't even show up in BIOS. I tried the power reset procedure for SSDs but it did no good. Well, this is unfortunate.

0

Check your SSD using GSmartControl, it's also for Windows. When I suspected my own SSD of failing I also tried SSD Life, but I'm not sure if its results are entirely accurate.

3
  • The problem is that the computer doesn't even know the SSD is there. I just tried GSmartControl and the only drive that shows up is the 24GB quick boot drive. The strange thing is, I'm currently running Ubuntu from the live DVD and if I close the lid, let it go to sleep, and then open it up again, my SSD briefly appears on the left hand side with the available drives. Seconds later, it goes away though. Apr 17 '15 at 18:43
  • Try running the tools from a separate computer with a dock, if you have one handy. My rule of thumb though is that if it doesn't show up under GSmart or GParted it's probably dead.
    – Ian
    Apr 17 '15 at 18:45
  • Unfortunately, I don't have another computer around to check it. This is pretty crazy, I've only been using the SSD for about 4 months. Apr 17 '15 at 19:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.