2

I have a serious overheating problem. I installed Ubuntu 14.10 2-3 days back and it is experiencing high overheat problems. I am using a Dell XPS L502X PC with Nvidia graphics. I know that I should use an optimizer like nvidia prime and bumblebee but the problem is that my PC wont stay on for more than 6-7 minutes after which it auto shuts down due to overheating and the machine is at a burning temperature.

I cannot download bumblebee as it is 512MB big and slow net and PC wont stay on.

Also, xsensor shows my core temp to be more than 80° Celsius. Any tips?

Edit:

Q1.Output

ashwin@ashsek:~$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
powersave
ashwin@ashsek:~$ 

Q2. will update later

Q3. No this never happened with my previous Os which was windows 8.1. I did a full wipe and installed ubuntu

Q4. No Pc dosent heats in bios

5
  • Please edit your post and i) add the output of cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor ii) tell us whether this also occurs if you boot into a live session (boot from the Ubuntu CD/USB) iii) clarify if this happened with your previous OS or, if you have another OS installed, if it happens with that one; iv) Enter your BIOS, there is usually a temperature monitoring screen there. Watch it for a few minutes, does the machine overheat even then? – terdon Apr 16 '15 at 15:33
  • Done Edited the question – Ukiyo Apr 16 '15 at 15:47
  • just to eliminate anything else that might be really obvious, use your system-monitor application and see if there is a 99%CPU process running (not likely, but may as well be sure). Good luck. – shellter Apr 16 '15 at 19:16
  • I have 4 cpus running and all of them shows usage above 30%. There are some fluctuations that one cpu suddlenly jumped b/w 70-100% – Ukiyo Apr 17 '15 at 0:03
  • firwfox is using more than 60% of CPU – Ukiyo Apr 18 '15 at 5:33
1

I'm with Lenovo but I had similar problems like you, because of the Nvidia card and after the installation of bumblebee everything became normal. The bad thing with your laptop is the shutting down and I have two ideas which could give you time for installing bumblebee. First - Start the laptop and when you see the GRUB choose Ubuntu advanced options and after that Run in graphic safe mode. If your computer shut down again try the next thing. When the login box of Ubuntu appears click ctrl + alt + f1 and after that I hope you should have more time to install bumblebee.

But for sure don't forget to check the running processes in System Monitor.

Wish you Luck! :)

3
  • Thanks but it is still overheating in ctrl + alt + f1 and still auto shutdown.... :(. Also it is overheating in graphic safe mode – Ukiyo Apr 17 '15 at 15:52
  • firefox is using more than 60% CPU – Ukiyo Apr 18 '15 at 5:32
  • When Ubuntu starts and you don't touch anything, does it shut downs again? If it only shutdown when you turn on firefox you can install bumblebee from the console. The another thing is to stay with ubuntu 14.04 and upgrade direktly to 15.04 when there is an official version. – Kasmetski Apr 18 '15 at 12:11
0

TLP brings you the benefits of advanced power management for Linux without the need to understand every technical detail. TLP comes with a default configuration already optimized for battery life, so you may just install and forget it.

To install TLP in Ubuntu:

sudo add-apt-repository ppa:linrunner/tlp
sudo apt-get update
sudo apt-get install tlp tlp-rdw

Restart your system after installation.

To remove TLP,:

sudo apt-get remove tlp
sudo add-apt-repository --remove ppa:linrunner/tlp
0

If you have overheating problems due to the nVidia card, I would:

  1. Disable the nVidia card in the BIOS or take it out of the PC
  2. Install 14.04.2 LTS (=Long Term Support)
  3. Install the nVidia modules (a.k.a. "drivers")
  4. Reboot and enable the card again
1
  • 3
    Don't thank me! ;-) If you like my answer, just click the little grey under the "0" now turning it into beautiful green. If you do not like my answer, click on the little grey down-arrow below the 0, and if you really like my answer, click on the little grey checkmark and the little up-arrow... If you have any further questions, go to askubuntu.com/questions/ask – Fabby Apr 17 '15 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.