2

I am using ubuntu 14.04 LTS, using MaaS as juju environment. After bootstrap I set proxy's:

juju set-env http-proxy=http://172.16.1.160 <-- My MaaS server IP

juju set-env no-proxy=http://172.16.1.160

And then deployed wordpress charm:

juju deploy –-repository=/opt/charms local:trusty/wordpress

Now juju status:

enter image description here

Hook failed: install, I have to do juju ssh 1 and check the logs in /var/log/juju.

enter image description here

In the unit-wordpress-0.log I got this:

enter image description here

enter image description here

And on the machine-1.log I got this:

enter image description here

The IP 172.16.1.176 - is the bootstrapped node, the juju-agent.

How do I solve this? Thanks in advance!

4

Ok, a few things:

a) The syntax for no_proxy is an IP or a hostname, separated by commas, not a URL. So yours should have been just the IP. That being said, I don't think you need (or should) specify the proxy itself in there. Take a look at https://jujucharms.com/docs/1.22/howto-proxies

b) I think you are missing a port in the http-proxy variable. Or did you really install a proxy on the MAAS node on port 80?

c) That all being said, I think you hit but https://bugs.launchpad.net/juju-core/+bug/1439447. After addressing the issues in (a) and (b), and if still doesn't work, can you try with an older juju-core, like 1.20.14, or maybe 1.23beta4 where it's supposed to be fixed?

  • a) I did this: juju set-env no-proxy=localhost,127.0.0.1,172.16.1.160, is it good now? b) Just now I tried juju set-env http-proxy=172.16.1.160:80 and it said it can't access the charm store, I didn't installed a proxy on the MAAS node on port 80, how do I do that? – Mario Apr 16 '15 at 20:21
  • You still don't have the exact right syntax for http-proxy. I edited the answer to include a link to the docs, please take a look at that. And I suggest that you bootstrap with those settings already in place in the environments.yaml file, so the bootstrap process can use the proxy too. As to how to configure a proxy, that's out of scope for this specific askubuntu question. – Andreas Hasenack Apr 17 '15 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.