I'm installing a new laptop and the touchpad is not fully recognized. Specifically, two finger scrolling does not work.

extract from /proc/bus/input/devices

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 FocalTech FocalTech Touchpad in mouse emulation mode"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input5
U: Uniq=
H: Handlers=mouse0 event4
B: EV=7
B: KEY=30000 0 0 0 0
B: REL=3

Also, xinput list gives me:

⎡ Virtual core pointer  id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer id=4   [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen id=10    [slave  pointer  (2)]
⎜   ↳ PS/2 FocalTech FocalTech Touchpad in mouse emulation mode id=14   [slave pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam                      id=11   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]

And finally, synclient tells me there is no synaptics driver active:

Couldn't find synaptics properties. No synaptics driver loaded?

So, it seems the touchpad is not recognized as a synaptics touchpad. It works, but not the synaptics specific parts.

It's in mouse emulation mode (no idea what it means). And it works together with other pointing devices, especially the touchscreen (I can confirm this works).

I have tried adding i8042.nomux=1 to the kernel parameters, but it didn't change anything... Any hint ?


I finally came to this bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1372609

It seems FocalTech touchpad needs a specific driver, and that work is in progress to integrate it into the mainline kernel.

currently, there seem to be a ppa to get a dkms driver for this touchpad : http://ppa.launchpad.net/hanipouspilot/focaltech-dkms

After trying this, I can confirm the following procedure works :

  1. add ppa

    sudo add-apt-repository ppa:hanipouspilot/focaltech-dkms
  2. update the packages database

    sudo apt-get update
  3. install the dkms driver

    sudo apt-get install focaltech-dkms
  4. reboot

The touchpad in now recognized. Two finger scrolling works, for example. Also, the zone where the buttons are won't make the cursor move.

Thanks for the community that retro-engeniered this (Asus just replied "no linux support nor technical information" to a request ! Very bad point to them (see the afore-mentioned bug report)).

  • Please select this as the answer to your question so that this issue can be marked as solved..
    – heemayl
    Apr 17 '15 at 21:05
  • 1
    Works for ASUS TP500L
    – h3nr1x
    Nov 22 '15 at 14:39
  • Also works for ASUS X453M Dec 3 '15 at 6:12
  • hate private repos. One year and it's absent...
    – vp_arth
    Oct 10 '16 at 16:23
  • 1
    Not working any more: The user named '~hanipouspilot' has no PPA named 'ubuntu/focaltech-dkms'. It shoulden't be necessary with kernels 4.2+, (check hanipouspilot github). Mar 29 '17 at 22:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.