0

I had ubuntu 14.04.2 LTS installed in dual boot with windows 8 with grub2 as boot manager. The problem arose when the updated windows 8 for windows 8.1, now grub is no longer displayed when starting and windows 8.1 is loaded automatically. To be able to access the grub, it is necessary that when the notebook is booting, press F12 (bios boot options), there is listed, among other things, Windows 8.1 and Ubuntu, only when I select Ubuntu grub2 screen appears showing the option to select: Windows OS loader, Ubuntu, Ubuntu and advanced options. So, I wonder what to do to start to load the grub screen automatically.

Thanks for any help!

0

This question was also answered here and here

The problem is that the Windows installer doesn't know about Grub or any other OS's boot loaders, so it usually replaces it with the Windows boot loader. The Windows boot loader only knows how to boot Windows.

This page describes how to recover your grub bootloader.

The preferred (GUI) method:

  1. use your Ubuntu CD and start a Live session (i.e. boot from the CD), or similarly boot from a Live USB.
  2. Install and run Boot-Repair
  3. Click "Recommended Repair"
  4. Reboot your system.

Grub should now appear. If it doesn't, hold down Shift during the reboot and you should be able to choose between Linux & Windows.

If you prefer the use the command-line, that's way more involved, see the link.

0

Thanks for the reply and sorry for the duplication, I found this other question. But solved the problem by changing the boot settings in the BIOS, I realized that to update the windows, he climbed to the top of the boot, the front of grub. Thank you and I'm sorry!

Not the answer you're looking for? Browse other questions tagged or ask your own question.