I was trying to create a LiveUSB with my SanDisk Cruzer on Ubuntu with the Startup Disk Creator program, then because of some reason it could not boot. I guess it was because I checked the Format USB option when I created the disk. After some time I wanted to install Ubuntu 11.04 through the USB, so I formatted the USB and used Pendrivelinux to create the LiveUSB (I was on Windows at that time). But the problem is that now my USB won't boot.

  • How did you format the drive? Fat 32? Fat 16? NTFS? – user4815 Sep 12 '11 at 17:37

Theres a good chance pendrive did not load an instance of grub on the USB Key that your bios could utilize/find. I know when i use DD to create my usb images, it depends on the format of the iso. Occasionally i have to specify the device node itself, or speicfy the first partition on that device.

dd if=awesomeness.iso of=/dev/sdc  OR   dd if=awesomeness.iso of=/dev/sdc1

so verify that you're writing the image properly to the usb key if your BIOS boot order has been changed. If pendrivelinux continues to fail to boot, you can always give the official LIVE CD a go and verify its not due to a poor image.

  • The same prosses has worked before and I have verified with virtuabox that the iso is ok and also the boot order is corrrect.And still it wont load. – Eitan Fishman Sep 12 '11 at 7:02

Check your boot order in BIOS. Make sure that your USB drive comes before the hard drive.

  • the boot order didn't change since the last time I booted from the usb. – Eitan Fishman Sep 11 '11 at 17:37

Try using unetbootin

There are versions for Linux and windows, on ubuntu you can install it with

sudo apt-get install unetbootin mtools

mtools is required for unetbootin, on some distros is installed by default, on ubuntu you need to install it.

just run that program, chose Iso File option and select your iso..

  • I tried it just like pendrivelinux on windows it didn't recognize the usb although the strange thing was that I told him not to boot from the hard drive but grub was booted regardless of the priority so maybe the problem is with grub taking over my system boot?On the other hand it does let me to boot from the cd rom so whats the problem here? I think it is the usb. – Eitan Fishman Sep 12 '11 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.