1

My desktop first failed to load unity, which doesn't repair with tries to reinstall unity and ubuntu-desktop. I couldn't configure them seems like lack of a proper driver. When I had a look at nvidia drivers, things seemed more strange: I didn't have nvidia drivers, neither checking by dpkg -l | grep nvidia nor update-alternatives for graphics driver, which said, I had only one option that is the default ubuntu driver.

But I knew I had cuda development tools installed on the desktop and I worked with GPU feature to accelerate a Python module's calculations. Cuda installed corresponding drivers at that time. When I had a look at cuda, the files are there, but I failed to test my script: modprobe: no nvidia module found.

The only thing I did before that happened, was boot into Windows 7 about to edit a word file. Maybe, there something else happened, but I didn't know because I wasn't always in front of my desktop. When I came back, unity dropped in infinite loop. And I didn't succeed to repair. That's another long story.

Even tried to revert system back with timeshift won't help me. I had backups, but they failed with same problem. And finally, when I boot with live CD again (before that I used it to restore system, it worked fine):

graphics driver fail, red flashing dashes on screen

Update:

Booted again to fetch the Xorg log file screen-related part:

...
[    20.974] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 16 11:21:21 2015
[    20.990] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    21.075] (==) No Layout section.  Using the first Screen section.
[    21.075] (==) No screen section available. Using defaults.
[    21.075] (**) |-->Screen "Default Screen Section" (0)
[    21.075] (**) |   |-->Monitor "<default monitor>"
[    21.076] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
...
[    21.880] (II) LoadModule: "nvidia"
[    21.880] (WW) Warning, couldn't open module nvidia
[    21.880] (II) UnloadModule: "nvidia"
[    21.880] (II) Unloading nvidia
[    21.880] (EE) Failed to load module "nvidia" (module does not exist, 0)
# other modules loaded successfully
...

The odd part is what happened to a fresh liveCD. Firmware incompatibility? Why I didn't have the problem before.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.