3

Normally when i press print screen button in the keyboard, I get gnome-screenshot windows as this ..

enter image description here

Is there a way to replace this windows with shutter edit screen or at least shutter main screen, When i press printscreen button ?

I have tried creating custom shortcut in All Settings ⇒ Keyboard ⇒ custom shortcut and added shutter -f ..

How to make Shutter as the default screenshot tool?

Instead of opening any windows with more edit options it just save the image.. Then i have to find the image and open with shutter...

Most of the switches i have checked in the above link with shutter.. and tried shutter help /google..

Yet could not get what i want.. I want to get shutter edit screen or at least shutter main screen with the image grabbed when i press printscreen.. Is this possible? What im missing here ? Please help

4

I tried it my self.... Here are the steps..

Disable gnome printscreen shotcuts .. (All Settings--->Keyboard---->Screenshots)

enter image description here

Next create shortcuts as preferred (All Settings--->Keyboard---->Custom shortcuts )

Shutter -f 

enter image description here

And assign printscreen key. ( See more for how to assign a custom key ) How to add keyboard shortcuts?

And next shortcut for shutter -a

enter image description here

And assign alt key and printscreen ( See more for how to assign a custom key ) How to add keyboard shortcuts?

Then open shutter and go to menu (Edit--->preference--->main) Select Do not save file automatically

enter image description here

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

At this point you have achieve main screen by pressing printscreen button or Alt + printscreen button.. +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

To open edit windows, instead of main screen, when ressing printscreen button or Alt + printscreen button, go to Actions in preference and select open with Built-in Editor

enter image description here

And make sure other settings remain as below in behavior section,

enter image description here

Done!!

  • 1
    Thank you for the solution. I've implemented it for me too. However, disabling the standard shortcuts is not intuitive. I've found that it works if you are using Alt+noting and wait - probably a workaround. Also the Alt+Print combination doesn't work, chose Shift+Print. – alex Sep 11 '15 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.