2

The default grub loader is always runing 10 second countdown before launching Ubuntu 14.04.

This is how it looks in etc/default/grub:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_RECORDFAIL_TIMEOUT=$GRUB_TIMEOUT
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

The RECORDFAIL line was added in an atempt to fix this problem. It did not help.

After making any change sudo update-grub is executed.

What could be causing this?

7
+50

You have enabled GRUB_HIDDEN_TIMEOUT_QUIET, but you haven't specified the timeout length of it (GRUB_HIDDEN_TIMEOUT=0is commented). This is why it is reverting back to 10 seconds.

Because GRUB_HIDDEN_TIMEOUT_QUIET has it's own timeout length config line, you need to uncomment the line making the timeout for it equal to 0.

Having GRUB_HIDDEN_TIMEOUT=0 and GRUB_HIDDEN_TIMEOUT_QUIET=true, will hide the GRUB menu on boot, which I assume is what you were attempting by making GRUB_TIMEOUT equal to 0.

  • Thank you, this answer also helped to hide the boot menu permanently since GRUB_TIMEOUT_QUIET doesn't work if there is another OS installed. – Gabriel Meono Apr 18 '15 at 5:30
0

You can install boot-repair. And set the timeout through advanced settings in boot-repair.

Click on the Advanced option on boot-repair Boot-repair starting menu

Now change the Unhide boot menu : 10 seconds to whatever time you want Advanced boot-repair

And click apply. If you wanted to install boot-repair checkout this link Installing Boot-repair

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.