3

I've a Asus laptop with windows 8.1 pre-installed, I've managed to install Ubuntu alongside it, and for some days it worked fine. Today, out-of-the-blue, Ubuntu just goes black screen and I'm back at the grub menu to select one of my OS's, when I tried to boot to Ubuntu, it just says it cannot mount '/boot/efi', and it doesn't let me select none of the options ( one is to press S to bypass the mounting process and the other is to press M to manually correct the problem). If I go through the recovery mode, and try to start up normally, it let me bypass the mounting procedure and startup Ubuntu as usual.

How do I deactivate the mounting process at the startup? Or better yet, how do I solve the problem?

2

The_Seppi's response answers your first question and is absolutely correct in that respect.

As to the question of fixing the problem, chances are that one of two things is happening:

  • There may be something wrong with the filesystem (filesystem damage). This can happen if you use the Windows "fast startup" feature, which is set by default. It's imperative that you disable this feature, as described here, among many other places.
  • Your filesystem ID may have changed. This is the UUID=xxxx-xxxx bit from the_Seppi's response. You can find all the UUID values for your partitions by typing sudo blkid. If your entry has something else in the first column for your EFI System Partition (ESP; /boot/efi in Ubuntu), such as /dev/sda1, then that value may have changed. Such changes can occur if you backed up, created a fresh filesystem, and restored; or if you repartitioned the disk.

The output of the Boot Info Script (in the boot-info-script package) may be helpful if these tips don't enable you to fix the underlying problem.

| improve this answer | |
1

Open the file /etc/fstab in a text editor with elevated privileges. You should be able to recognise the EFI partition at once, as it will likely carry a label, such as this:

# /boot/efi was on /dev/sda1 during installation
UUID=xxxx-xxxx  /boot/efi       vfat    defaults        0       1

In order to prevent automatical mounting, append the noauto flag to the options column (where, in my example, "defaults" is standing), separated by a comma, so it might look like this:

UUID=xxxx-xxxx  /boot/efi       vfat    defaults,noauto 0       1

This will prevent automatical mounting of this partition in the future. Should you encounter the need to access the partition, you can mount it manually by running sudo mount /boot/efi. As this directory is stored in the fstab entry, mount will automatically know what to mount there.


NOTE: On my system, the /boot/efi entry was commented out. However, it is being automounted, too. So if you're going to change the fstab entry, remove any prepending #'s in front of the UUID=... /boot/efi line.

| improve this answer | |
  • So it worked, problem is something really wrong happened with Ubuntu, because now it can't use wireless network and also unity doen't appear with tranparency, I've just went to other distro now, and things look ok yet – Duarte Azevedo Apr 16 '15 at 20:13
  • To make sure it's really related to this, try removing noauto again and reboot. If you experience the same issues, it's an independent problem. – s3lph Apr 16 '15 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.