6

I want to install PyQt5 as mentioned on the official documentation.

Here is the ouput of the command they asked to run:

begueradj@begueradj-hacker:~/Bureau/PyQt-gpl-5.4.1# python configure.py 
Querying qmake about your Qt installation...
Determining the details of your Qt installation...
This is the GPL version of PyQt 5.4.1 (licensed under the GNU General Public
License) for Python 2.7.6 on linux2.

Type 'L' to view the license.
Type 'yes' to accept the terms of the license.
Type 'no' to decline the terms of the license.

Do you accept the terms of the license? yes
Found the license file pyqt-gpl.sip.
Error: Make sure you have a working sip on your PATH or use the --sip argument
to explicitly specify a working sip.

How to fix this ?

Note that I have installed correctly SIP:

begueradj@begueradj:~/Bureau/sip-4.16.7# python configure.py 
This is SIP 4.16.7 for Python 2.7.6 on linux2.
The SIP code generator will be installed in /usr/bin.
The sip module will be installed in /usr/lib/python2.7/dist-packages.
The sip.h header file will be installed in /usr/include/python2.7.
The default directory to install .sip files in is /usr/share/sip.
Creating siplib/sip.h...
Creating siplib/siplib.c...
Creating siplib/siplib.sbf...
Creating sipconfig.py...
Creating top level Makefile...
Creating sip code generator Makefile...
Creating sip module Makefile...
7

you need to install sip first (not just configure it)

begueradj@begueradj:~/Bureau/sip-4.16.7# python configure.py 
begueradj@begueradj:~/Bureau/sip-4.16.7# make
begueradj@begueradj:~/Bureau/sip-4.16.7# make install

and next you can install PyQt :

begueradj@begueradj:~/Bureau/PyQt-gpl-5.4.1# python configure-ng.py

or

begueradj@begueradj:~/Bureau/PyQt-gpl-5.4.1# python configure-ng.py --sip /usr/bin/sip  
|improve this answer|||||
  • To install sip run apt-get install python-sip-dev – Drakonoved Sep 16 '17 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy