0

Fglrx Not working after install (I know)

HW : Asus K72j with AMD HD5470 laptop

So, after installing the ATI drivers fglrx on my ASUS K72J laptop via CL my screen booted black.

So at first I thought I had broken my computer and had to make a fresh install. After using my wifes laptop I found out fglrx does something with the backlight. Also I thought it might have something to do with me running 14.10 instead of 14.04.

Since I really wanted the drivers to work (using garmin basecamp on windows vmware) I figured I had to reinstall (I am a noob) 14.04.

So after making a fresh install of 14.04 I sudo apt myself to the latest available fglrx drivers in the repo's just to find out that I booted a black screen again. Using my wifes laptop I found out that fglrx still(or also)has problems with the backlight in 14.04

With a torch and settings set to high contrast I could somewhat work my way through some stuff and one was that the fglrx drivers were working properly, I could even launch the catalyst control centre. Just to see everything was working perfect, except backlight.

So with a torch I worked myself through some webpages and solutions which all did not work. I sudo apt xbacklight – which installed fine – adjusting did not work.

looking at /sys/class/backlight/acpi_video0 i could see all brightness settings seems to be as they should be.(at least as i think they are allright)

furthermore I used this page as a reference :

After installing fglrx on Ubuntu 14.04 there is no backlight (hd 5470). Is there any workaround?

Short list of things on the page :

  • Try adding acpi_backlight=legacy or acpi_backlight=vendor (not both) as a kernel parameter. (in GRUB, with the update GRUB command afterwards)
  • sudo apt-get install xbacklight, then set xbacklight XX
  • xrandr --output LVDS1 --brightness 0.9
  • sudo setpci -s 00:02.0 F4.B=xx ( this does not work because I thing my - - VGA is on 00:01.0 using that in the command does not help)
  • video.use_native_backlight=1(or 0) in grub with no result

some things that i have noticed: I disabled quiet boot in GRUB, so i can see the boot phase quite verbose. everything works fine, but just before the login screen appears the screen goes black.

Further I have used the page

https://wiki.ubuntu.com/Kernel/Debugging/Backlight#Debugging_information_to_provide_in_your_bug_report

and used the techniques provided. Which all lead me to thing there is actually nothing wrong with the settings. The backlight just does not come alive with the drivers installed/loaded.

Creating the udev rule mention on this wiki did also not work for me (maybe I did something wrong , not sure if I had to udevstart before reboot)

https://wiki.archlinux.org/index.php/backlight

But that refers to arch linux not ubuntu ( allthough I tried some things from that wiki as well)

Looking at the xorg.conf i notice that even with the removed fglrx drivers the screen should use fglrx drivers

Section "Device"

Identifier "aticonfig-Device[0]-0"

Driver "fglrx"

BusID "PCI:1:0:0"

This might be because i did not generate a new xorg.conf file after i purged the fglrx driver?

So, using dmesg > dmesg.txt i cannot really find a difference in using the fglrx driver or without using the fglrx driver

Both state

[ 21.231381] asus_laptop: Asus Laptop Support version 0.42

[ 21.232100] asus_laptop: BSTS called, 0x5800 returned

[ 21.232121] asus_laptop: model detected

[ 21.232599] asus_laptop: Backlight controlled by ACPI video driver

there are lots of differences between the 2, but since i was looking for backlight issues this might be the most important lines?

-Is there anybody who can help me out a little more, or give me a push in the right direction in solving the issue? (except using the ubuntu drivers) -is there an option that i need to know about with the fglrx drivers to enable the backlight?

  • I experienced the same issues. I fixed it by fetching the latest beta fglrx from AMD's website and install it over the one installed from the repos. – s3lph Apr 13 '15 at 22:48
  • so you first installed fglrx from the repo's, and without removing/purging the driver you installed 14.12 from AMD's website? – Diet Bos Apr 14 '15 at 4:45
  • I cleared the fglrx setup (sudo aticonfig --initial), installed the Xorg open drivers again, then installed the beta drivers, again ran sudo aticonfig --initial and then rebooted. – s3lph Apr 14 '15 at 8:04
  • Tnx for your effort, but did not work. I tried it this time with the beta drivers, too bad it did not work. CAn somebody else point me in the right direction for finding out what triggers the backlight on an asus laptop? – Diet Bos Apr 23 '15 at 20:09
0

Older Asus laptops have the same problem on Windows 8.1. The solution there is:

go into Power Options, Edit Plan Settings of the active plan, set Change plan brightness to the maximum for both battery and plugged in. You can access the same setting under Change advanced power settings, Display, Display Brightness.

You can still control the brightness using the keyboard. The control panel setting seems decoupled from the keyboard setting (I am guessing it is a driver issue that is at the root of the problem).

I haven't found a way to fix it on Ubuntu yet, but this might be a place to look.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.