6

My laptop screen goes blank (everything else responsive otherwise) after a random number of seconds (of active use, not idle) of booting the OS.

I've noted, everything is fine after fresh installation, going to the google.com/chrome link malfunctions it permanently. Same issue with Ubuntu 12.04 LTS, 14.04 LTS and Linux Mint 13. I've Intel Mobile 965 Express chipset.

Do anyone know the fix? I don't know a lot of command-line, so please suggest an easy solution, if any at all.

  • Do you have a dual boot system or a single boot system? – Eka Apr 17 '15 at 6:36
  • @Eka. Tri boot actually, others being Windows Server 2008 & 2008R2. I've Ubuntu installed using Ext4 partitions though, it is not a Wubi install. Bootloader & MBR also is that of Ubuntu. – Abdullah Leghari Apr 17 '15 at 6:40
  • Whether the same problem exists when you boot from windows? if yes then i suggest it may be due to the hardware problem and you should show it to some technician. – Eka Apr 18 '15 at 3:40
  • 1
    Not a hardware problem I believe. Windows works just fine. And I've yet to see a technician in my country who knows something named Ubuntu exists :) – Abdullah Leghari Apr 18 '15 at 17:44
  • 1
    @AbdullahLeghari What I would do would be to enable SSH on the machine and connect through another computer (running Ubuntu to keep this simple) and try to debug it. I am not running Ubuntu myself anymore so I do not know the exact steps on debugging Ubuntu but if you look up the commands and tricks of the trade of checking the system logs and such you might find something that could help us others that are more experienced with Ubuntu to give you some real help other than suggestions. It is quite hard to get anywhere without any kind of logs or data. – Simon Apr 20 '15 at 11:31
1

I've just had the same issue today, on a freshly installed 15.04. My problem was about the animation on the Google Chrome download page, and my graphics card's driver's not being able to handle it. I am using an Nvidia graphics card, so I tried installing proprietary Nvidia driver and problem solved.

I suggest you try installing/updating the driver for your graphics card, to do so you can check Additional Drivers tab of the Software & Updates in System Settings:

Additional Drivers

  • What makes you think that it is a Nvidia graphics? – A.B. Apr 18 '15 at 17:22
  • It is WebGL content probably on chrome download page. I've tried after un-installing Adobe Flash player, still no luck. Problem is, it is not one time issue, after first visit to google.com/chrome damage is permanent. I've Intel 965 Mobile, not NVidia. Couldn't find drivers / updates anywhere :( – Abdullah Leghari Apr 18 '15 at 17:48
  • @A.B. I didn't think that he's using Nvidia graphics card if that's what you ask, I just wanted to share more details about my case to make it easier for Abdullah Leghari. – Gokhan Sari Apr 18 '15 at 21:43
  • 2
    @AbdullahLeghari I don't know much about Intel graphic cards but you can check here for Intel graphic cards' drivers: 01.org/linuxgraphics – Gokhan Sari Apr 18 '15 at 21:46
1
+50

I had a similar problem on a mac-book using the Intel 965 graphics chip-set after i used the isight camera built in and after extracting the drivers for the camera using the tools for Ubuntu. the issue was with the default drivers. after i searched the Intel website for Linux drivers it gave me an updated driver i installed and it fixed the issue. you have to search for the drivers using the search box at the top of the page. good luck.

  • Awarded the bounty because your observations proved to be right. The issue was in driver. I couldn't update the drivers, everything I went with ended with an error message of its own. – Abdullah Leghari Apr 24 '15 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.