0

I installed a new Epson L355 (wifi) printer in my home router (I did it from the MS Windows boot of my desktop computer). From my desktop computer after booting in Ubuntu 12.04 I could install it and use it without any problem. Later I tried to install it in a Samsung notebook (with Ubuntu 12.04 also) but I am having problems with it.

I started installing (in the notebook) the epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb driver and installing the printer in CUPS through localhost:631.

I could even print a test page correctly from within CUPS.

Then I went to the Printers option (now I am using classic gnome) but no printer appears. Only a message with something like "printer service not available" (I am translating). If I write localhost in the Connect field then I can see the printer (I could also print a test page from here). But the printer does not appear when I want to print from within any application.

CUPS is currently installed and running (I checked that). I tried reinstalling CUPS and it did not work. I also looked at the /etc/cups/error_log file but I don't understand much of what is written there.

Here goes the last part of it:

D [12/Apr/2015:14:28:56 -0300] cupsdCloseClient: 13
D [12/Apr/2015:14:28:56 -0300] cupsdSetBusyState: newbusy="Dirty files", busy="Dirty files"
D [12/Apr/2015:14:28:56 -0300] cupsdReadClient: 16 WAITING Closing on EOF
D [12/Apr/2015:14:28:56 -0300] cupsdCloseClient: 16
D [12/Apr/2015:14:28:56 -0300] cupsdSetBusyState: newbusy="Dirty files", busy="Dirty files"
I [12/Apr/2015:14:29:26 -0300] Saving subscriptions.conf...
D [12/Apr/2015:14:29:26 -0300] cupsdSetBusyState: newbusy="Not busy", busy="Dirty files"

What should I do?

2

Taken from here on Ubuntu Forums:

It finally works!
I found what I think could have been the reason for my troubles. > There was an innocent-looking file /etc/cups/client.conf with the single line in it:

ServerName 192.168.1.36. 

It was probably left after a previous attempt to print to another printer. Apparently after uninstalling cups completely that file was not erased (I thought everything was erased). I commented that line and started again.

Then after restarting cups I ran system-config-printer again and choose the options that the program offered me by default. So in the end I did not use the ipp option (I could not find the correct path to make it print). I do not know if it is safe or good but the option suggested in the URI address was:

dnssd://EPSON%20L355%20Series._pdl-datastream._tcp.local/

and that has worked perfectly so far.

0

As praseodym says, the static addresses need to be outside the range used by the router for DHCP. For example, if the router (in your case, the DSL appliance supplied by your ISP) assigns DHCP addresses from 192.168.1.2 to 192.168.1.50, for example, use static addresses from x.51 on up.

If you have Network Manager installed, you will find the process difficult unless you Edit Connections in NM and set the details there. Please see attached.I think there are two reasons. If a server is running headless, without a desktop manager, there is no other way to do it. Running headless means no keyboard, monitor and mouse. It means the overhead imposed by a windowing manager is lifted and, best of all, you can stick the thing in a closet or garage.

  • Abdullah, thank you so much for your comments. Let me see if I understand you. Did you mean that I must configure the wifi printer with a static address and be careful which number I choose? But I was doing that configurations through the router's software. I don't understand where and why I should use NM. And I didn't see any attachment. Thanks again. – guaicuru Apr 13 '15 at 0:28
  • Followed your suggestion but the problem persists. Apparently the printing administration of the laptop is searching for printers in a fixed server with IP 192.168.1.36 that was configured for a different printer in that static address (in the top of the Printers Administration menu says "Printing 192.168.1.36") . When I want to add the new printer (in the laptop) I don't know how or where to change this fixed IP address. If I press the "Connect" button and write "localhost" instead there then the printer is shown (but I cannot use it from my applications). – guaicuru Apr 13 '15 at 18:26
  • Finally solved in ubuntuforums.org/showthread.php?t=2273501 – guaicuru Apr 20 '15 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.