0

I recently installed ncurses and from then on I have been getting similar errors while trying to install new libraries

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 lib64ncurses5-dev:i386 : Depends: lib64c-dev:i386

After I run apt-get -f install I hit another wall

The following NEW packages will be installed:
  libc6-dev-amd64:i386
0 upgraded, 1 newly installed, 0 to remove and 548 not upgraded.
6 not fully installed or removed.
Need to get 0 B/1,429 kB of archives.
After this operation, 9,590 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 451168 files and directories currently installed.)
Preparing to unpack .../libc6-dev-amd64_2.19-0ubuntu6.6_i386.deb ...
Unpacking libc6-dev-amd64 (2.19-0ubuntu6.6) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-amd64_2.19-0ubuntu6.6_i386.deb (--unpack):
 trying to overwrite '/usr/include/gnu', which is also in package libc6-dev-i386 2.19-0ubuntu6.6
Errors were encountered while processing:
 /var/cache/apt/archives/libc6-dev-amd64_2.19-0ubuntu6.6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
5
  • did you try sudo apt-get dist-upgrade? – JoKeR Apr 12 '15 at 15:18
  • getting You might want to run 'apt-get -f install' to correct these. – Saurabh Apr 12 '15 at 15:23
  • run sudo apt-get install --reinstall lib64c-dev:i386 – JoKeR Apr 12 '15 at 15:27
  • Got the same error as when I executed apt-get -f install – Saurabh Apr 12 '15 at 15:40
  • follow the steps provided here askubuntu.com/questions/140246/… – JoKeR Apr 12 '15 at 15:42
0

Things went back to normal after I uninstalled the package having dependency issues: lib64ncurses5-dev:i386.

1
  • Thanks. I've fix this issue by using: apt remove lib64ncurses5-dev:i386 and apt autoremove – Marslo Mar 13 '17 at 12:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.