I've been looking around for hours to find a driver or a solution to get my wifi working on my new laptop (Acer Aspire V 17 nitro).

But without success.

I have a fresh Ubuntu 14.04 Installed,

This is the result i get from lspci -vnn | grep Network

Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 20)

I have been googling for hours, is there no solution ?

Will I have to get a usb wifi adaptor and get a wifi connection like that ?

For the QCA6174 probably the easiest thing to do is upgrade to Ubuntu 15.10 (you can use the Ubuntu software updater rather than installing 15.10 from scratch) as this has the kernel 4.2 and the ath10k firmware

  • Tried it out with 15.10 but I still can't get wifi to work. – RVandersteen Jan 12 '16 at 23:50
  • using dmesg i still get something like: ath10k_pci 0000:07:00.0: Direct firmware load for ath10k/QCA6174/hw2.1/firmware.bin failed with error -2 [ 3.719535] ath10k_pci 0000:07:00.0: could not fetch firmware (-2) [ 3.719537] ath10k_pci 0000:07:00.0: could not fetch firmware files (-2) [ 3.719538] ath10k_pci 0000:07:00.0: could not probe fw (-2) – RVandersteen Jan 12 '16 at 23:51
  • Are the ath10k kernel modules loaded (they refer to ath10k/QCA6174/hw2.1/firmware.bin)? In terminal try: lsmod | grep ath10k. Something like ath, ath_pci, ath10k_core along with mac80211 and cfg80211would be what you're looking for. If they are loaded try unloading using rmmod and then reload them using modprobe. – rustynuts Jan 24 '16 at 21:34
  • If that doesn't work try downloading the ath10k firmware from the github page listed on linux wireless. Copy and paste where the old ath10k folder (you may need to rename a .bin file so that it matches what is supposed to be in the directory-ath10k/QCA6174/hw2.1/firmware.bin). Again reload the ath10k kernel modules using rmmod and modprobe (or restart your system). – rustynuts Jan 24 '16 at 22:06

protected by Community Jan 24 '16 at 6:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.