2

I am using ubuntu server 14.04 LTS, have 3 nodes to deploy wordpress, mysql and juju-gui. After I deployed wordpress, it went pxe boot to install the OS and then I got this error, but first of all im going to share the setup I did.

sudo apt-get update && sudo apt-get install juju

juju generate-config - did my conf for MaaS environment

And because sometimes after bootstrap I get restricted or don't get internet access, I downloaded the juju tools - wget - c https://streams.canonical.com/juju/tools/releases/juju-1.20.11-trusty-amd64.tgz and added to juju environment conf file

tools-metadata-url: http://172.16.1.160/juju-metadata/tools

juju bootstrap

sudo apt-get install bzr

mkdir –p /opt/charms/trusty; cd /opt/charms/trusty

bzr branch lp:charms/wordpress

juju deploy –-repository=/opt/charms local:trusty/wordpress

and then the error, after the pxe boot:

enter image description here

enter image description here

How do I solve this issue? Thanks in advance!

enter image description here

enter image description here

enter image description here

  • 1
    Could you run sudo add-apt-repository ppa:charmers/charm-helpers and add the output to your question? – zhongfu Apr 12 '15 at 2:44
  • Added 3 printscreens – Mario Apr 12 '15 at 20:53
1

I suspect your MAAS node cannot reach out to the internet to install the necessary software. The charm-helpers PPA is being used by the node, not your local machine.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.