2

I had a pretty vanilla install of 12.04 running on a headless server with a software RAID1 array. I ran do-release-upgrade to upgrade to 14.04, and it seemed to run without issue. The only mistake I think I may have made was that it prompted me to update or keep the grub file, and I told it to update, but I don't think I had anything custom there.

Now, I never get to a prompt. When I boot, I get the Ubuntu-themed grub select screen, but selecting the default option results in a long never-ending scroll of messages that are scrolling too fast for me to makeout. Each line seems to be formatted like:

[  433.8979798] ata1.00: some message

I can catch some messages like "device error" and "error: (ABRT)", but it's too much of a blur.

If I had to guess, I'd say it's having trouble mounting my md0 RAID partition, but I can't confirm. I've tried selecting different kernels, including recovery mode, but they all result in the same stream of messages.

How do I fix this?

Edit: I found that if I select the server recovery mode kernel, after a few minutes of messages, it does eventually drop a recovery menu which lets me drop out to a root shell, but I'm not sure where to go from there. Nothing seems to work. It says eth0 is up, but all IPs and domains it says are unreachable.

0

Boot your system from live DVD or live USB, then install boot-repair and run it. The following pages help to install and run boot-repair.
https://help.ubuntu.com/community/Boot-Repair
How to install the Boot-Repair tool in an Ubuntu live disc?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.