I have installed MySQL Workbench in the past using MySQL APT.

My software repositories lists have recently been updated and since then my MySQL Workbench disappeared. It is still on the disk but it is not launching.

I tried to go to Software Center and try to install it and I receive:

mysql-workbench: Depends: libgcc1 (>= 1:4.1.1) but 1:4.9.1-0ubuntu1 is to be installed
                 Depends: libgtkmm-2.4-1c2a (>= 1:2.24.0) but 1:2.24.4-1ubuntu1 is to be installed
                 Depends: libpcrecpp0 (>= 7.7) but 1:8.31-2ubuntu2 is to be installed
                 Depends: python:any (>= 2.7.1-0ubuntu2) but it is a virtual package
                 Depends: mysql-workbench-data (= 6.0.8+dfsg-2) but 6.0.8+dfsg-2 is to be installed

If I try to install from APT using

sudo apt-get install mysql-workbench

I get

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mysql-workbench : Depends: mysql-client
                   Recommends: mysql-utilities but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Then if I try to install mysql-client dependency, I get a similar error saying that it needs mysql-community-client.

If I try to install this community client, I will receive another error saying that it needs libstdc++6 (>= 4.9) but 4.8.2-19ubuntu1 is to be installed.

If I try to install this one, it says that I already have this version.

What can I do?


This error occurs because the mysql-community-client package you are trying to download and install requires libstdc++6 >=4.9. The latest version of libstdc++6 available on the Ubuntu 14.04 LTS repositories is 4.8.2-19ubuntu1, which is older than 4.9.

I'm assuming that you're running Ubuntu 14.04, because the libstdc++6 package on your computer is stuck at 4.8.2-19ubuntu1. The MySQL APT repository currently has packages for three versions of Ubuntu: 12.04, 14.04 and 14.10. mysql-community-client for 12.04 and 14.04 both require only libstdc++6 >=4.6, while 14.10 requires version libstdc++6 >=4.9.

Please check that you've installed the correct mysql-apt-config package for your Ubuntu version.

| improve this answer | |
  • 1
    This was the problem. I installed the wrong version of APT. I installed APT for 14.10 instead of 14.04. Thank you! – tzortzik Apr 11 '15 at 17:25

You should:

sudo apt-get install -f mysql-workbench

I use in such cases aptitude

sudo apt-get install aptitude

and then:

sudo aptitude install mysql-workbench

Suggestions are made that can help solve your problem.

| improve this answer | |
  • Forcing MySQL Workbench installation did not solve my problem. Instead, I installed aptitude and probably this would've solved the problem somehow. I didn't go further with this because I already applied @zhongfu's answer. – tzortzik Apr 11 '15 at 17:26
  • @tzortzik, I think that you have chosen the correct answer. My answer is a bit too general. – A.B. Apr 11 '15 at 17:29
  • @zhongfu Were you satisfied with my answer? Then give me a upvote (∧). If I could solve your problem, then it would be nice if you'd mark my answer (✓). ;) – A.B. Apr 18 '15 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.