I have the same problem, a 32 bits toshiba nb255, it first had the windows 7 bu next I installed the ubuntu 11.04. The wifi does not turn on. I used the following issues

  • the commands rfkill unblock wlan0, sudo ifconfig wlan0 down; they were not able.
  • by setting up the bios in advanced menu, the wireless communication sw in ON, but it did not work also.
  • neither the utilities toshiba nor utilities of ubuntu (wicd, wifi radar).
  • by using gedit to file group, nothing.
  • by installing madwifi packet, nothing.
  • by exporting the wifi driver from windows to ubuntu, by means of the NDISwrapper packet, neither.

I put the current scripts of the ouput of the cli

root@zorrillo:~# rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

root@zorrillo:~# sudo lspci | grep Atheros
07:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

root@zorrillo:~# ifconfig -a
eth0      Link encap:Ethernet  direcciónHW 88:ae:1d:47:df:e1  
          ACTIVO DIFUSIÓN MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:0 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:0 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000 
          Bytes RX:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupción:43 Dirección base: 0xe000 

lo        Link encap:Bucle local  
          Direc. inet:  Másc:
          Dirección inet6: ::1/128 Alcance:Anfitrión
          ACTIVO BUCLE FUNCIONANDO  MTU:16436  Métrica:1
          Paquetes RX:8 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:8 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:0 
          Bytes RX:480 (480.0 B)  TX bytes:480 (480.0 B)

ppp0      Link encap:Protocolo punto a punto  
          Direc. inet:  P-t-P:  Másc:
          Paquetes RX:6384 errores:30 perdidos:0 overruns:0 frame:0
          Paquetes TX:6893 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:3 
          Bytes RX:5473081 (5.4 MB)  TX bytes:974316 (974.3 KB)

wlan0     Link encap:Ethernet  direcciónHW 00:26:4d:c3:d0:44  
          DIFUSIÓN MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:0 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:0 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000 
          Bytes RX:0 (0.0 B)  TX bytes:0 (0.0 B)

note.-it is logical all the counters are cero if the wireless device is down

root@zorrillo:/home/zorrillo/Descargas/802BGA# ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill  

It would seem the wireless switching does not react with whichever ubuntu 11.04 command (I hope to be wrong). The target remains the same, in order of the scripts above.

I am worried, I have tried to find any answer for days and nights. Toshiba does not supply drivers or soft support for linux, marketing of course.

I only see the device is up by protocols and down phisically, My question is, is it possible to enable or not shutdown physically the device?, because in the toshiba model nb255 the wifi is not set up/down bye means of a physical switch, but by means a combination of Fn + F8 (only for windows 7, no one more), Is there one possibility to configure the hot keys in ubuntu?


Thank you for your wealthy help.

Now, I have solved this issue by using the following. We most agree that is a temporal method while we haven't a final solution:

The machine is Toshiba NB255-SP1002M, 32 bits, originally with Windows 7 starter in Spanish. In this machine you can up the wireless device (AR9285) ONLY via software (no via hardware exist) by pressing Fn + F8. This profile is managed by means a Toshiba support utility named TVAP Toshiba Value Added Package (versionv1.3.6; 04-09-2010; 44.36M).

Normally, by shutting down the wireless device (with Fn + F8) we save charge in the battery; so in some time I turned off the device. After I booted the machine and then I installed Linux Ubuntu 11.04 Natty N. Finally, it is when I saw the abnormally that you say me in order to my initial question above, because I understand you when you said me if I had accidentally shut it down.

I discovered that at the time there is not an utility in Linux for a TVAP (unfortunately, TVAP exists only for Windows platform, as far as I know). So, the solution was to recover Windows 7: I made a little partition (20 GigaBytes) so I installed it. I downloaded the TVAP utility in www.toshiba .com and installed it. Then I have a principal partition for Ubuntu 11.04 and secondary partition for Windows 7. Now, I am able to turn on and of the AR9285 in the Windows 7, so I finally turn it on. Next, I restarted to Ubuntu and I fortunately I have:

root@zorrillo:~# root@zorrillo:~# rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no root@zorrillo:~#

root@zorrillo:~# lshw -class network *-network
description: Wireless interface product: AR9285 Wireless Network Adapter (PCI-Express) vendor: Atheros Communications Inc. physical id: 0 bus info: pci@0000:07:00.0 logical name: wlan0 version: 01 serial: 00:26:4d:c3:d0:44 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=ath9k ip= latency=0
multicast=yes wireless=IEEE 802.11bgn resources: irq:17 memory:f0100000-f010ffff

Before, I had the parameter *-network DISABLED in the last command. Note, now we can see that the "DISABLED" word does not already exist.

The only manner to manage the AR9285 in Ubuntu via hardware is by playing whit the BIOS utility when restart the machine. It could be annoying, remember it is provisional for me while TVAP does not exist for linux. Unfortunately, I am not software developer for support this weakness. I advert I have proved whit UBUNTU 11.04 and 10.04 LTS and for both, It is the one manner that I have know now.

It is not uncomfortable for me. Really the Windows 7 is encapsulated in a little space of 20 Gigabytes; and meanwhile I have available 220 Gigabytes for linux, so what's the problem?

Yo maybe decide to erase Windows 7 (once you have turn on the wireless device with the windows TVAP utility, if you want you can write erase of your hard disk), however I prefer remain the Windows 7 for any similar problem.

So, the next challenge is to create the TVAP utility in linux platform; maybe it is necessary to apply inverse engineering at the TVAP Toshiba Value Added Package. So, who will be the valient? hahaha. However I'll try.

Thanks guys, a salute from Coatzacoalcos, México.


The wifi card is hard-blocked - this could either be a kernel issue or if you had accidentally/abnormally shutdown the machine, you just need to remove the rfkill blocking device i.e.

sudo rm /dev/rfkill

Then reboot.

If this doesnt work - please add to your question the output of sudo lshw -class network

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.