30

I semi-frequently experience what seems to be a minor yet very annoying bug when using the workspace switcher, starting in 14.04. I had never noticed this in earlier releases of the OS.

Essentially what happens is I get temporarily stuck in the workspace switcher screen (what shows after clicking the "Workspace Switcher" icon) displaying the 4 different workspaces. Normally you would just click one of the workspaces then ubuntu zooms back in on that workspace for you, however clicking the workspaces seems to do nothing when I am hung up.

This seems to happen only some of the time when I am using the workspace switcher to move an open window, say a nautilus file manager window to another workspace.

I have found that frantically pressing esc and/or the windows button at least 10 or 20 times eventually takes me back to a single workspace view. Also that if that mouse is moved every time I press the windows button the window I was moving in between the ws borders will be updated in position on the screen otherwise it will not move on the ws switcher screen.

How can I prevent this from happening?

  • If this is supposed to be a question, you should ask one, and if it is a bug report, it will probably receive more attention if reported the usual way – fifaltra Apr 11 '15 at 11:41
  • 1
    Something similar happened to me today. Things got stuck as if I was dragging a window between desktops. Although it isn't a fix, pressing ALT + ESC got it 'unstuck'. – cavpollo Mar 21 '16 at 21:31
  • If this is a regular issue for you, have you tried moving an active window to another workspace by using the combination Shift+Ctrl+Alt and one of the direction keys (up, down, right or left) according to preference? – User Jul 16 '16 at 9:50
  • This happens to me frequently in 16.04 LTS as I drag an application from one window to another. It is so frequent that I try to avoid doing that because it is more likely than not. – SDsolar Apr 25 '18 at 17:32
42

Alt+Enter does the trick hope it helps you

| improve this answer | |
  • 4
    Worked for me on 16.10. – Joseph Drane Oct 22 '16 at 16:07
  • This should be the accepted answer! – Blairg23 Oct 27 '16 at 3:27
  • 2
    yes , it really does it but why it is happening at the first place , can u tell me ? – Bhawin Feb 5 '17 at 7:19
  • I have not experienced this issue on 16.XX, I still utilize workspace switching frequently but for me at least, this problem was only existent in the 14.XX releases – John Dream Feb 22 '17 at 16:37
  • to me it happened in 16.04 and most probably because I was running a process that was taking all 4 cores and ram and swap may be ram is the issue. – abdul qayyum Jul 2 '17 at 22:12
2

Exact same problem happens with 16.04 LTS. Moving active windows inn the Workspace Switcher very often causes the GUI to hang, with Unity grayed-out. The windows can still be seen to be updating (and my cron jobs use espeak to talk to me) so I know the underlying system is still running.

Here is one clue as to why: It seems to happen most often when the window between workspaces is being updated a lot, such as a FileZilla window during a transfer, or even the System Monitor.

To recover, just press Alt-F1

This causes it to jump immediately to one of the four workspaces. Seems to pick the workspace that contains the upper-left corner of the application that was being dragged.

Afterwards, everything works normally again.

  • Tested successfully in Ubuntu 16.04 LTS on two systems with this issue.
| improve this answer | |
  • Alt+F1 = Lifesaver. Thanks. – copper.hat Sep 10 '19 at 20:31
1

I was having this problem. Seemed to have found a workaround by:

  1. Install unity-tweak-tool
  2. workspace settings -> restore defaults

Note that turning the workspace switcher off and setting the number of workspaces to 1 did not work. Windows would get moved off screen and become inaccessible. Thankfully the "restore defaults" seems to work.

| improve this answer | |
  • 3
    WARNING!!! This caused my desktop environment (Ubuntu 16.04) a big mess. The launcher and the taskbar disappeared. I couldn't fix this problem and I had to move to a new user. – mustafa Jun 23 '16 at 11:33
  • I tried editing the title of this question to include 16.04 but that edit got rejected. In my experience it happens a lot more often in 16.04 than it used to in 14.04 – SDsolar Apr 26 '18 at 1:21
0

not sure if this is a complete answer as to the behaviour, but what worked for me was to have a key bound to workspace switching using Ubuntu Tweakor compiz. When I get stuck and cant use the mouse to get out, I simply use the hotkey to get out.

This seems like a better workaround than having to reset all the parameters every time (besides, Im not sure how you could try and reset something if you are stuck in the preview mode)

| improve this answer | |
  • what is the hotkey to get out? – mustafa Jun 23 '16 at 11:34
  • I had it set to something custom. (Shift & end) I am not sure what default is. You could just restart your machine go into compiz and set a custom binding for yourself. if it ever happens again then at least you will be able to escape – Kalamalka Kid Jun 23 '16 at 20:41
  • 1
    @mustafa alt + enter – Paulo Coghi - Reinstate Monica Sep 27 '16 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.