4

I'm finding that the video quality setting on Youtube videos only has the options "Auto" and "360p". My browser is Firefox 37.0.1 and I'm using Ubuntu 14.04 LTS 64 bit, and my motherboard chip-set is Intel 965GM (I believe) and is using Xorg open source driver.

Additionally, I have higher quality options available in the dedicated Youtube application from the Ubuntu software center, however I would prefer to use my browser.

Any advice on how to enable higher quality settings would certainly be appreciated!

sudo lshw -class display returns:

*-display

       description: VGA compatible controller
       product: Mobile GM965/GL960 Integrated Graphics Controller (primary)
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:43 memory:f6e00000-f6efffff memory:e0000000-efffffff ioport:efe8(size=8)



*-display
       description: Display controller
       product: Mobile GM965/GL960 Integrated Graphics Controller (secondary)
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:f6f00000-f6ffffff
  • 1
    Do see higher quality options on youtube.com/watch?v=iApvUMgk5Mo for example? – Elder Geek Apr 10 '15 at 23:51
  • Please edit your question and include the output of sudo lshw -class display – Elder Geek Apr 11 '15 at 0:13
  • I've amended the question to include that information, however I recently uninstalled and then reinstalled firefox and now that link you suggested @ElderGeek has higher quality options, and other videos do too! I will check to see if flash is also installed from the software centre. The solution seems rather simple after all that, but thank you for your assistance. – Tom Boynton Apr 11 '15 at 10:47
  • One slight oddity is that sometimes the video doesn't load at all, and requires reloading the page. – Tom Boynton Apr 11 '15 at 10:48
  • Flash is installed now, nothing seems to have changed drastically but I guess it helps to have it installed. (Hope this isn't considered spam, I'm new here). – Tom Boynton Apr 11 '15 at 10:54
1

My browser is Firefox 37.0.1 and I'm using Ubuntu 14.04 LTS I have numerous quality options available ranging from 144p all the way up to 1080p in the browser. All I've ever needed to do is install Adobe Flash plugin from the software center here:

flashplugininstaller

If this solution doesn't work for you, drop a comment letting me know and include the output I requested and I will edit my answer.

  • Reinstalling Firefox and installing this plugin has corrected my previous issue, however now there is a slight problem that I mentioned in the comment thread attached to my original question; a video often requires that I reload the page for it to properly load. Thanks for the assistance so far. – Tom Boynton Apr 11 '15 at 11:01
  • @TomBoynton I'm glad this helped you. Askubuntu is a Q & A site, not a forum. What you are asking here is a second question, which has to do with something entirely unrelated to the first question. (possibly related to networking or perhaps installation of the youtube application). I couldn't find anything related to your exact problem to refer you to, so please ask a new question by clicking the box in the upper right corner of the page. – Elder Geek Apr 11 '15 at 12:13
  • thanks for the advice, I'm new to the stack exchange format. I'll open another question if the issue worsens. – Tom Boynton Apr 11 '15 at 14:34
2

Head to about:config page and check if the following keys are set to true:

media.mediasource.enabled
media.mediasource.mp4.enabled
media.mediasource.webm.enabled

After that, install the packages gstreamer1.0-libav and gstreamer1.0-plugins-good with

sudo apt-get install gstreamer1.0-libav gstreamer1.0-plugins-good

Restart Firefox and go to https://www.youtube.com/html5. You should see something like the following image:

Screenshot of HTML5 support in YouTube

This solution worked for me and I didn't have to install any third-party software such as FlashPlayer or Firefox Extension. I've came up with this solution by looking at the Arch Linux Wiki > Firefox Tweaks > Enable Additional Media Codecs.

1

Using flash player isn't recommended by firefox anymore, you should be using the standard html5 player. I had the same problem and found the solution on ubuntuforums.

Go and check Youtube HTML5 support. If you find most of them are marked as not available (red exclamations) then that's your problem.
Solution: 1.Open a new tab and type about:config in the address bar.
2.Firefox will give you a warning that its not safe and to be careful. Proceed.
3.Search for media.mediasource.enabled and change its value to true (double clicking works).
4.Search for media.mediasource.webm.enabled and change that to true too.
5.Recheck the above youtube link. Most of the options should be enabled now and more video qualities should be available too.

0

That is because Flash player is not supported for Firefox in Linux any more or at least the latest version.

To solve your problem you can either use Google Chrome or Chromium-browser with Pepper Flash Plugin.

If you still want to use Firefox then do the following steps

sudo add-apt-repository ppa:skunk/pepper-flash
sudo apt-get update
sudo apt-get install pepflashplugin-installer
sudo mkdir -p /opt/google/chrome/PepperFlash
sudo ln -s /usr/lib/pepflashplugin-installer/libpepflashplayer.so /opt/google/chrome/PepperFlash

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install freshplayerplugin
  • I followed these terminal commands however this resulted in youtube not loading videos at all, advising that I ensure "libpepflashplayer.so" is installed. I took a screenshot of the entire error message but I'm unsure about how to link this in a comment. – Tom Boynton Apr 10 '15 at 19:04
  • I managed to remove the new key I installed and have gotten back to my starting position. – Tom Boynton Apr 10 '15 at 19:30
  • You should have not removed it. I will update the answer for you try it again and see if it solves your problem. – Maiwand Apr 10 '15 at 19:45
  • I updated the answer it should now solve your libpepflashplayer.so problem. @TomBoynton – Maiwand Apr 10 '15 at 19:53
  • Thanks for all the help so far @Don, however now that I have followed the updated terminal code, whilst I no longer get that error message, no videos actually play now. I can get by with this for now if a solution can be found but if not perhaps I should just go for google crome? – Tom Boynton Apr 10 '15 at 22:42
0

You can try adding an extension/plugin for FireFox named "Youtube Flash Player".

It will definitely solve your problem.

-1

Actually google automatically define this according to you internet speed. There is nothing to setup manually by users.

  • I've checked with different devices (my tablet) using the same connection and that plays higher quality videos fine. Unless something about my laptop is limiting my internet speed (I haven't noticed any performance drops downloading or browsing though). – Tom Boynton Apr 10 '15 at 19:12
  • @Imran, this is 1/2 correct. The gear icon (Settings) that shows up on the bottom bar on youtube videos allows for settings including quality, granted auto is also an option but other options include 144p, 240p, 360p, 480p, 720p. This may be video dependant but thus far I haven't been able to prove that. – Elder Geek Apr 10 '15 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.