8

I have Ubuntu 14.04.2 installed on a Lenovo S21e-20. To get things like two-finger-scrolling or suspending the touchpad during typing, I wanted to install xserver-xorg-input-synaptics but installation fails with two unmet dependencies due to held broken packages (command outputs below). All those packages should be installed already by default (my installation is fresh, this is the first thing I do on this system after wi-fi driver installation).

Output of sudo apt-get install xserver-xorg-input-synaptics:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 xserver-xorg-input-synaptics : Depends: xorg-input-abi-20
                                Depends: xserver-xorg-core (>= 2:1.14.99.902)
E: Unable to correct problems, you have held broken packages.

Output of sudo apt-get install xorg-input-abi-20:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'xserver-xorg-core' instead of 'xorg-input-abi-20'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libcheese-gtk23 : Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but it is  not going to be installed
               Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libcheese7 : Depends: libclutter-gst-2.0-0 (>= 0.10.0) but it is not going to be installed
              Depends: gstreamer1.0-clutter but it is not going to be installed
 libclutter-1.0-0 : Depends: libcogl-pango15 (>= 1.15.8) but it is not going to be installed
                    Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Trying to install xserver-xorg-core aborts with a similar problem, i.e. the same unmet dependencies.

I tried sudo apt-get clean, sudo apt-get update, sudo dpkg --configure -a and sudo apt-get -f install, but all those did not solve the problem. No held packages are shown.

Trying to install the unment dependencies of xserver-xorg-core directly, shows that they are already installed.

How can I resolve this?

  • Could you please add the full command outputs instead of just quoting small snippets? Thank you! – Byte Commander Apr 10 '15 at 20:08
1

A good way to solve these problems is to use aptitude.

sudo apt-get install aptitude
sudo aptitude update
sudo aptitude install xserver-xorg-input-synaptics

Now several ways to solve the problem will be proposed by aptitude:

Choose the solution that uninstalls the least packets. Write down what packages are removed. Install the packages again if needed.

  • 1
    hmm. aptitude talks about a couple of colliding dependencies. As a recommendation it wants to remove ubuntu-desktop, but I am not so certain about that... – Till B Apr 17 '15 at 18:04
  • ubuntu-desktop is only a meta package. You can reinstall ubuntu-desktop later. – A.B. Apr 17 '15 at 18:06
  • @TillB Choose the solution that uninstalls the least packets. Write down what packages are removed. Install the packages again, you still need. – A.B. Apr 18 '15 at 14:03
  • @TillB Were you satisfied with my answer? Then give me a upvote (∧). If I could solve your problem, then it would be nice if you'd mark my answer (✓). ;) – A.B. Apr 18 '15 at 14:59
  • I am still working on it, currently it does not boot again – Till B Apr 19 '15 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.