0

My brand new Lenovo X250 came with a Windows 8.1 pre-installed. I wanted to dual boot with Ubuntu 14.04 as I did on my previous computer. I started by disabling UEFI, removing Windows 8.1 , changing partition table to the older (was it msdos?) formatting and reinstalling windows, and installing Ubuntu to the other partition.

Everything worked nicely as well as booting the first time to Windows. But after that I cannot boot to Windows 8.1. After selecting windows form grub, the display remains dark and nothing happens. Ubuntu boots nicely without any problems.

I was confused and formatted all partitions and tried to install everything again from scratch leading exactly to the same thing!

Boot repair or switching between legacy and UEFI booting doesn't seem to help either.

What could be the problem here?

  • have you installed 32 or 64 bit ubuntu – Alejandro Apr 10 '15 at 12:29
  • Oh sorry, forgot to mention. 64-bit. Anders answer uodating the grub resolved my problem. – olltsu Apr 10 '15 at 12:34
1

Have you tried updating the grub boot loader with:

sudo update-grub
  • 1
    Unbelievable, that seemed to do the trick! That was 8 hours of my life being resolved in 6 minutes :) – olltsu Apr 10 '15 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.