5

I have done everything I can to set Google Chrome as my default browser in Ubuntu 12.04, but absolutely nothing seems to work. Anything new I could try would be greatly appreciated.

Whenever I open Chrome, Chrome displays the message 'Chrome is not the default browser' with the button 'Set as default as browser'. This message does not disappear. I also cannot install extensions in Chrome, which always returns the following error:

Could not install package: 'UTILITY_PROCESS_CRASHED_WHILE_TRYING_TO_INSTALL'.
Could not install package because a utility process crashed.
Try restarting Chrome and trying again.

I read somewhere (I forgot where unfortunately) that this error is related to the error of refusing to be the default browser.

Additionally, when I open Chrome from the command line, it opens successfully but I do get an error message:

$ google-chrome-stable
LaunchProcess: failed to execvp:
/proc/self/exe

So here the list of things I already tried:

== Things I tried ==

Simple things

  • System Settings -> Details -> Default Applications

    Chrome is set correctly here as the default browser, but I still get the error messages.

  • Use the 'Make Google Chrome the default browser' button in the Chrome settings. This button does nothing when I click it. It's not disabled, it just does nothing.
  • Reinstalling Chrome.
  • Setting $BROWSER - this variable was empty by default and setting it to google-chrome did not help.

mimeapps.list

I edited ~/.local/share/applications/mimeapps.list, and it currently looks like this:

[Added Associations]
application/x-executable=gedit.desktop;
image/png=eog.desktop;
x-scheme-handler/http=google-chrome.desktop;
x-scheme-handler/https=google-chrome.desktop;
image/svg+xml=inkscape.desktop;
application/pdf=inkscape.desktop;

[Default Applications]
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
image/svg+xml=inkscape.desktop
text/html=google-chrome.desktop
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/about=google-chrome.desktop
x-scheme-handler/unknown=google-chrome.desktop

This doesn't solve the problem.

defaults.list

I removed all mentions of 'firefox' in ~/.local/share/applications/defaults.list. Everything seems to be set correctly to google-chrome.desktop, but I still get the error message.

xdg-settings

sudo update-alternatives --config x-www-browser

returns the following:

There are 2 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path                           Priority   Status
------------------------------------------------------------
* 0            /usr/bin/google-chrome-stable   200       auto mode
  1            /usr/bin/firefox                40        manual mode
  2            /usr/bin/google-chrome-stable   200       manual mode

Switching between these options did nothing.

  • 3
    What happens when you try Chromium? It is the open-source web browser project from which Google Chrome draws its source code. The browsers share the majority of code and features, though there are some minor differences in features and they have different licensing. – Noosrep Apr 10 '15 at 10:06
  • I hadn't considered that yet. Are all extensions from Chrome also available in Chromium? If the functionality is similar enough, using Chromium might be an acceptable solution. – ComboCosmo Apr 10 '15 at 12:38
  • 1
    To be honest, I don't see any difference (except the icon color) with Chrome. Give it a try I say. Also because I'm curious if it's really a Chrome problem you encountered or Ubuntu related – Noosrep Apr 10 '15 at 13:19
  • @ComboCosmo All extensions from the chrome store are available on Chromium :) – GamingWessel Jun 11 '17 at 19:03
0

Use sudo apt-get install chromium-browser and install chrominum browser. AFAIK, it is same as chrome and should work without any problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.