0

I'm new to Ubuntu, Webmin and Squid So I'm following the tutorial to set up my squid proxy server on webmin

I'm able to start the webmin and squid. But unfortunately after I got to the step where we have to initialize the cache, it failed miserably.

it said

Error - Perl execution failed

Can't use string ("Directory-Name") as a HASH ref while "strict refs" in use at parser-lib.pl line 118.

I have searched all over the web and can't find the solution. I haven't modified the squid.conf too. When I try to remove the # from one line of squid.conf

( Open the file /etc/squid3/squid.conf. Search for the line #cache_dir ufs /var/spool/squid3 100 16 256 (around line 2245). Remove the "#" character.) based on tutorial from http://www.techrepublic.com/blog/smb-technologist/configure-a-squid-proxy-server-through-webmin/ , the squid server can't start.

Can someone help me with a solution? Thanks :)

  • run this command and check output for squid configuration "sudo squid -k check" – PKumar Apr 10 '15 at 10:10
  • @PKumar this is what happen when I'm trying to do that command WARNING: Cannot write log file: /var/log/squid3/cache.log /var/log/squid3/cache.log: Permission denied messages will be sent to 'stderr'. – soulvt13 Apr 12 '15 at 8:59
  • squid do not have permissions to write on "/var/log/squid3" make squid services as owner user must be "proxy" below is example "chown -R proxy:proxy /var/log/squid3 && chmod 755 /var/log/squid3 " – PKumar Apr 13 '15 at 6:58
1

Press the button "Clear and Rebuild Cache". This action will recreate cache dirs as you set it in cache_dir option

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.