5

It was working and one day it decided not to work anymore. I can click on the lock screen button or use Ctrl+Alt+Del but no reaction. How to fix that?

I am using Xubuntu 14.04

6

Lock is a function of the screensaver. It will stop working if your screensaver is not running - for example, if it gets removed your start-up applications.

Go to: Settings > Session and Start-Up > Application Autostart

And check: [x] screensaver.

Otherwise, it may not be likely your screensaver would stop working unless it has actually been removed. It is operated by the script called xflock4, which you will find in the directory /usr/bin/. It checks for three different possible screensavers and will run whichever one happens to be there: xscreensaver, light-locker or gnome-screensaver. To rule out the possibility that your problem is that you somehow lost your screensaver, simply attempt to install one (e.g. with the command 'sudo apt-get install xscreensaver'). If the program is already installed, it will tell you so. It seems the xfce4 panel button to 'lock screen' runs xflock4. It should also be set to operate by keyboard shortcut (CTRL-shift-L), which you can see by going: Settings > Keyboard > Application Shortcuts.

3

Assuming you have XFCE:

Try to run xflock4 from console.

If it works:

Go to the Settings manager -> Keyboard -> Shortcuts

Update Ctrl+Alt+Del to run xflock4

1
  1. Select Settings Manager -> Session and Startup > Application Autostart and enable light-locker, which is titled Screen Locker (Launch screen locker program).

  2. Open the terminal with Ctrl+Alt+T and run killall light-lockerto restart light-locker with the changed settings.

  • Could you explain in more detail how to apply your answer as a solution? – Kevin Bowen Jul 19 '16 at 3:39
  • This option used to prevent from locking your PC from automatically. – Sundar Pichai Aug 4 '16 at 23:39
  • Thanks! In my case, "Screen Locker" was disabled in "Settings > Session and Startup > Application Autostart". I just enabled it back and now its working. – Zugor Jan 30 at 5:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.