4

I am unable to find any bluetooth devices.

I was able to fix it by using this, but since the Ubuntu kernel update this fix has stopped working.

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter


3.16.0-34-generic #45~14.04.1-Ubuntu SMP Tue Mar 24 11:13:52 UTC 2015 i686 i686 i686 GNU/Linux
3

You follow similar instructions to when you first installed

cd rtlwifi_new
make clean
make
sudo make install

And for bluetooth

git clone -b troy https://github.com/lwfinger/rtl8723au_bt.git
cd rtl8723au_bt
make
sudo make install

Reboot

October 2015 edit, Pilot6 has a PPA with a dkms module that doesn't need to be reinstalled after a kernel update

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms linux-firmware rtl8723au-bt-dkms

Reboot and done

7
  • I do this several times and same result do not work – Alejandro Apr 9 '15 at 21:47
  • Bluetooth would also need github.com/lwfinger/rtl8723au_bt/tree/troy as it isn't supported in any kernel yet or git command would be git clone -b troy https://github.com/lwfinger/rtl8723au_bt.git – Jeremy31 Apr 9 '15 at 22:07
  • You Are Awesome woks finally works!!!!! – Alejandro Apr 9 '15 at 22:17
  • There is an error. it is not "cd rtl8723au_bt-troy", but "cd rtl8723au_bt". Branch does not change directory. – Pilot6 May 21 '15 at 20:48
  • @Pilot6 At the time, that is the way it worked as I tried the commands on my own laptop. It has changed since and cd rtl8723au_bt is what works now – Jeremy31 May 21 '15 at 23:33
1

Please try:

sudo apt-get install git
git clone https://github.com/lwfinger/rtl8723au_bt.git
cd rtl8723au_bt.git
make clean
make
sudo make install
sudo modprobe rtk_btusb

You should be all set.

NOTE: According to this: https://github.com/lwfinger/rtlwifi_new/issues/18 the driver covers all Realtek BT devices.

4
  • I made all as you say. I download again and made all steps make clean make sudo make install Still not work – Alejandro Apr 9 '15 at 21:41
  • Please see my revised answer above. – chili555 Apr 9 '15 at 22:06
  • doesn't work on Ubuntu 18 – Skyrocker Jul 16 '20 at 9:50
  • @Skyrocker Very few 5 1/2 year old answers involving kernel modules still work today as kernel versions, gcc, etc. have rapidly changed. Please start a new question and we'll be happy to help. – chili555 Jul 16 '20 at 13:48
1

I made a ppa with DKMS driver from lwfinger. It builds against all supported Ubuntu kernels. Install it by running

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms rtl8723au-bt-dkms linux-firmware
3
  • I'm using your ppa, I can see the device with hcitool devices... but when i try to connect with bluez i get "host is down" (I can connect if I use a USB adapter) – J.Serra Jul 20 '15 at 16:45
  • 1
    @J.Serra You need also sudo apt-get install rtlwifi-new-dkms. But you will need to remove alternative wireless drivers, if you installed any. – Pilot6 Jul 20 '15 at 16:47
  • My bad, I forget to install a package. WiFi and BT are working. – J.Serra Jul 20 '15 at 20:22
0

Jeremy31 answered this in a comment:

Bluetooth would also need github.com/lwfinger/rtl8723au_bt/tree/troy as it isn't supported in any kernel yet or git command would be git clone -b troy https://github.com/lwfinger/rtl8723au_bt.git

0

Until now I've spent hours to read in different threads to let my bluetooth work reliable.
I'm using Mint Rafaela 17.2 on a HP 350 G2 with a RTL8723BE device. But for sure you can transfer this workaround to Ubuntu

These things I found out for my notebook:

  • Bluetooth works only when OS starts with connected AC power. With battery you will encounter in terminal by entering hciconfig -a following output

    "Can't read local name on hci0: Connection timed out (110)"
    
  • Sometimes ISCAN is not enabled automatically. So you need a sudo hciconfig hci0 piscan. Then retry hciconfig -a to check.

  • I updated the driver with

    sudo add-apt-repository ppa:hanipouspilot/rtlwifi
    sudo apt-get update
    sudo apt-get install rtlwifi-new-dkms linux-firmware rtl8723au-bt-dkms
    

    Did a reboot

  • In a terminal I entered:

    hciconfig -a  # To check first if you have running PISCAN ISCAN.
    pactl load-module module-bluetooth-discover && pactl load-module module-switch-on-connect
    

    You should get for both modules a number. In my case 24 and 25.

  • If you get an error like

    module initialisation fails
    

    then I did a

    sudo service bluetooth restart && pulseaudio -k
    pactl load-module module-bluetooth-discover && pactl load-module module-switch-on-connect
    

    Now you should get the numbers.

  • With sudo hcitool scan you should now find your bluetooth device you want to pair. Like: mydevice 08:DF:1F:1F:82:0C

  • Try now to search the device with your bluetooth applet. I installed blueman, bluez-utils and bluez-tools.

  • If till now everything worked fine. Congrats. Now you can connect your device and enjoy it.

  • I made a script to access to my BT device by shortcut (ex. AltC). My script for my Bose Soundlink - soundlink.sh (executable file):

    service bluetooth restart
    pulseaudio -k
    sleep 10
    pactl load-module module-bluetooth-discover && pactl load-module module-switch-on-connect 
    bt-audio -c 08:DF:1F:1F:82:0C # you need to change it with the address of your device
    

    To disconnect you can make a new shortcut like (Altd) with the following command:

    bt-audio -d 08:DF:1F:1F:82:0C #address of your device
    

Now everything works fine for me and I hope it can also be helpful for you. I'm very happy that I found this thread. Thank you a lot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.