4

The hotkeys for Workspace Switcher stopped working after yesterday's 14.04 update/upgrade. Any thoughts on how to get this working again?

I already have reviewed other similar posts concerning configuration. This post is not a duplicate of Ubuntu 14.04 workspace switch hotkeys because (a) the Desktop Wall plugin is enabled in Compiz; and (b) the hotkeys worked before yesterday's update/upgrade.

Appearance > Behavior > Enable Workspaces is on.

System Settings > Keyboard > Shortcuts > Navigation has the standard "Switch to workspace" shortcuts specified.

I launched CompizConfig Settings Manager and saw nothing amiss.

I also can launch the Workspace Switcher from the icon and move among workspaces with the mouse and cursor keys. The problem is simply getting the hotkeys to resume working.

  • possible duplicate of Ubuntu 14.04 workspace switch hotkeys – Sh1d0w Apr 9 '15 at 15:45
  • Welcome to askubuntu. Please help us help you by clarifying which hotkey combinations aren't working, what they are, what they do when you use them and what you expected them to do. A screen shot of "nothing amiss in CCSM" uploaded to imgur.com and a link edited into your question might also be useful – Elder Geek Apr 9 '15 at 15:54
  • 1
    The hotkey combinations that ceased working are Ctrl-Alt-[right arrow], Ctrl-Alt-[left arrow], Ctrl-Alt-[up arrow], and Ctrl-Alt-[down arrow]. What I expect these hotkey combinations to do is what they did before yesterday's update/upgrade, what they are documented to do, and what in the Keyboard settings they are programmed/set to do, viz: change workspaces right, left, up, or down, respectively. Currently, these hotkey combinations do nothing. – ebsf Apr 9 '15 at 19:39
  • This post is not a duplicate of askubuntu.com/questions/524339/… because (a) the Desktop Wall plugin is enabled in Compiz; and (b) the hotkeys worked before yesterday's update/upgrade. Not certain how to get a screenshot to post, but the Desktop Wall bindings for Move Left, etc., in Compiz are identical to the hotkeys specified in the Keyboard Shortcuts settings. – ebsf Apr 9 '15 at 19:39
  • This answer helped me resolve this issue. I had to run CCSM as user (rather than using sudo). – klenwell Aug 24 '15 at 0:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.