2

I wish to set the default program to open .jpg files and other image files to GIMP. To do this as said in one of the answers here, I went into this section (Right-click > Properties > Open With):

Open With Properties Image Viewer

And selected GIMP Image Editor from the list of Recommended Applications, then I clicked the button Set as default, and this is what I then saw:

Open With Properties GIMP

And then sure enough when I right-clicked on a file of the file type that I had changed the default program for, the normal Image Viewer:

Image Viewer Right-click

Had been replaced with:

GIMP Right-click

But yet when double-clicking on a program, it still opens in Image Viewer and not GIMP, even though in all the settings it still says that that the default is now GIMP.

So really that is my question, why is this happening and how can I fix it?


OS Information:

Description:    Ubuntu 14.10
Release:    14.10
  • I see that the first link you have mentioned might be somehow useless, but I can't believe that none of the answers of the second link should work! Please explain what you did and why it did not work as you expected... – Byte Commander Apr 8 '15 at 17:42
  • @muru: Well, on the answer about the tweak tool did not work, nor could I find the button which sets as default. And basically the same with the other answers, either a button just did not exist or it just didn't work for some other reason. Mostly though either a file or button was not there. – user364819 Apr 8 '15 at 17:43
  • 1
    I bet this becomes an exceeded discussion - shouldn't we better move over to the chat room and come back to this question when we found a solution or at least know the problem? – Byte Commander Apr 8 '15 at 17:48
  • @muru: Ok, I have had a further look into it and it seems that the button was there but just faded out so I did not notice it, I also had not clicked on a different program from the one that was default so it stayed faded out. Although now that I click on a program and click the set default button, no apparent change to my system is made. Well, I don't see the desired change anyway. – user364819 Apr 8 '15 at 17:52
  • 1
    @muru: I should now probably re-write my question now to include that information... – user364819 Apr 8 '15 at 18:00
5

For some of the system default apps you can go to System Settings/Details e.g.:

Or for more advanced you can open Ubuntu-Tweak and go to Admins section and click on File Type Manager:

To install Ubuntu-Tweak:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

P.S.

I see you edited a bit your question you want Gimp to open all your photos or pics right? Using my workaround please do mention also that if you change from Image Viewer to Gimp it doesn't mean that you will open all photos with Gimp because this setting serves for .jpg/.jpeg and Gimp for example saves its work in .png portable network graphics by default and the default for .png will be Image Viewer anyways :) so to change that you need to configure all photos formats using Ubuntu-Tweak so they open with Gimp when you double click on them.

0

You can use the settings editor. Choose the Mime type, and search for images: enter image description here

Then change the relevant types to your likings:

enter image description here

As you can guess I use Shotwell to crob images. Change those to your favorit app!

  • Where is the settings editor? – user364819 Apr 8 '15 at 17:49
  • @Toroidal He refers to the System Settings panel. But I fear this MIME-Editor is only available on XUbuntu, not inside the Unity DE... :-( – Byte Commander Apr 8 '15 at 17:52
  • @ByteCommander: Yes, this does appear to be something not existent in my machine. – user364819 Apr 8 '15 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy