After DBANing my hard drive I installed Ubuntu 14.04LTS and quickly realised I've been unable to change screen brightness. This isn't too much of an issue when AC power is plugged in as the screen seems to display at 100% brightness, however on battery power it only displays at 40% which can be too dim to see in some situations.

After running lspci -v | less in a terminal, my video card is

VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller

Attempted fixes:

  • Edited the GRUB_CMDLINE_LINUX_DEFAULT variable in /etc/default/grub to be "quiet splash acpi_osi=Linux", "quiet splash video.use_native_backlight=1" and ran sudo update-grub and rebooted both times.
  • Installed xbacklight and changed backlight percentage to be 100. This produced no change but running xbacklight command in terminal returns 100.0
  • Added a file 20-intel.conf to /usr/share/X11/xorg.conf.d/, with contents

    Section "Device" Identifier "card0" Driver "intel" Option "Backlight" "intel_backlight" BusID "PCI:0:2:0" EndSection

as detailed on itsfoss.

  • Added a .conf file to etc/X11/ with contents

    Section "Device" Identifier "Configured Video Device" Driver "intel" Option "Backlight" "intel_backlight" EndSection # Section "Monitor" Identifier "Configured Monitor" EndSection # Section "Screen" Identifier "Default Screen" Monitor "Configured Monitor" Device "Configured Video Device" EndSection

as detailed on another askubuntu question.

Additional info:

  • In the /sys/class/backlight/intel_backlight directory, entries for actual_brightness, brightness and max_brightness are all 4882.

  • I've installed graphics drivers from Intel, however when I go to System Settings→Software & Updates→Additional Drivers tab "No additional drivers available" is displayed.

This is my first question on askubuntu so if there's any other information to make this post easier to solve or even read, please feel free to tell me.


Managed to fix this problem.

It seems the issue arises because I'm using a linux kernel which is later than version 3.16 and so to stop it using it's own backlight interface the kernel parameter video.use_native_backlight=0 had to be added to the bootloader. (GRUB_CMDLINE_LINUX_DEAFULT variable in /etc/default/grub)

Fix came from the backlight page on the ArchWiki.

  • Possibly daft question but did you try installing the latest graphics drivers from Intel? (downloadcenter.intel.com/download/13815/…) Also this looks like a possible solution that you haven't tried yet. itsfoss.com/fix-brightness-ubuntu-1310 Hope that helps – user396026 Apr 8 '15 at 10:25
  • 1
    Edited my post to show that I'd tried the fix on itsfoss but sadly to no avail. I installed the drivers but when I go to System Settings→Software & Updates→Additional Drivers tab "No additional drivers available." is displayed, any ideas on that? – BlairA15 Apr 8 '15 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.