3

Updated from 14.04 to 14.10. Now PyCharm is starting with its vertical line in the middle of the editor. Searched the entire settings and couldn't a find solution. This article talks about disabling the "wrap-guide" or edit "stylesheet"?

  • 1
    What do you mean vertical line in the middle of the editor, ? There is multiple options in Pycharm where lines in the editor are optional, which one are you talking about ? – amrx Apr 8 '15 at 8:47
  • Picture and code example in the article. – user93097373 Apr 8 '15 at 8:52
  • 2
    This article are mainly talking about Atom Editor! and not Pycharm this code is to Atom configuration. – amrx Apr 8 '15 at 9:02
5

The vertical line in the picture can be disabled by going to Settings. Ctrl+Alt+S or from File -> Settings -> Editor -> General -> Unbox Right Margin

enter image description here

|improve this answer|||||
2

In PyCharm there is a vertical line at 120 columns to indicate a suggested maximum line length. To disable the vertical line:

Settings -> Editor -> Colors & Fonts -> General, select Right margin, uncheck the checkbox for Foreground
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.