I tried to use my computer to distributed computing projects World Community Grid/Outsmart Ebola Together and World Community Grid/FightAIDS@Home. It worked nicely but yesterday the Boinc started to say just:

Not connected to a client.

Does anyone has some ideas why it says so? Now it looks like I have no tasks to do and I'm not part in any research project. And it seems to be impossible to attach any projects as the menu Add project or account manager... just closes the drop-down menu. Is this a bug or is there some setup I need to check?

The version is 7.2.42 (x64) and wxWidgets version 2.8.12.

  • Where is it saying "Not connected to a client" Are you using the manager? Have you tried to connect to a project? If so, which one and by what means? – neanderslob Apr 8 '15 at 8:26
  • I'm using the manager. I have LXDE desktop and when I move the mouse above the boinc-logo in a Panel, the pop-up has the text. When I tried to connect a project, there is no a window where I can select the project. – Jaakko Seppälä Apr 8 '15 at 8:29
  • And have you tried connecting the client to a project yet? – neanderslob Apr 8 '15 at 8:30
  • I tried but the menu add project or account manager ... won't do anything except it closes the drop-down menu. – Jaakko Seppälä Apr 8 '15 at 8:33

After reproducing your error, I was able to get it running by following the general linux start instructions here.

First, kill all boinc processes including the manager:

sudo killall boinc
killall boincmgr

Then start the daemon:

sudo /etc/init.d/boinc-client start

Fire up your manager again and give it a shot.

I also found a system restart can provide roughly the same effect.

Let me know if this does the trick.


I have the same problem. boinc-client and boincmgr were running nicely for months, and then one day I noticed that my list of Tasks was gone, so I checked the Projects tab and they were gone too, and then I noticed the "Not connected to a client" icon at the bottom of the screen.

I have uninstalled boinc-client and boincmgr, restarted the computer, reinstalled, no change. I'm not able to add my projects.

I then tried:

sudo killall boinc

killall boincmgr

sudo /etc/init.d/boinc-client start

No change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.