2

I am very new to Linux. I installed Ubuntu, tried to add a /home partition, messed up, formatted again, etc. Then finally I added /home by selecting "Something Else".

Now I can see that I have a /home in gparted but I can't see anything in File System GUI! Below is a screen shot of my gparted

enter image description here

Below is a screen shot from my file system

enter image description here

How can I access this /home partition? All I can see is a home folder in Computer

  • 3
    Double click on the /home folder, there you will find your personal folder. The mounted partition is visible as a folder. – Jacob Vlijm Apr 8 '15 at 8:15
  • everything is a file – mchid Apr 8 '15 at 8:18
  • 1
    " How can I access this "/home" partition?" Linux does not show you partitions in the file browser and puts it ALL together as 1 big area of files and directories where /home/ IS a partition but also a directory and you see this directory in your image. We do not have a D: where you need to go to a different disk. – Rinzwind Apr 8 '15 at 8:18
  • 1
    @mchid nope. Everything is a file descriptor ( anonymous pipes and network sockets are not files ;-) ) – Rinzwind Apr 8 '15 at 8:20
  • @JacobVlijm: I have no /home folder. I have a "home" folder. – Lemon Juice Apr 8 '15 at 9:01
2

In the first screenshot, there is a KEY next to the blue square in the third line. That means that the partition is mounted, so theoretically, you ought to be able to access it, and I think you ARE accessing it without realizing it.

By giving it the mount point of /home, one of the "homes" of your directory system is that entire partition. I'm guessing it is the higher one and I'm going to enumerate the steps to determine if I am correct.

  1. Navigate your file manager so that your screen looks just as it is in your second screenshot.

  2. Click on the back arrow in the upper left corner.

  3. You should see a screen with probably only two folders in it, and one of them should be named for your account name, "Yohan" apparently.

  4. Right click on "Yohan" and select properties. If I'm correct the free space on that folder should be over 200 gb, proving that the folder is in fact the partition you seek.

| improve this answer | |
  • Thanks for the reply. When I open the file manager, what get opened is "home" which is under "places" category of file manager. So if I access "Computer" clicking the back arrow will take me back to "Home" section. – Lemon Juice Apr 8 '15 at 9:04
  • I see. I'm comparing that to my file manager. As I'm using version 12.04LTS, it would appear to be slightly different. I do have a devices menu but no option called "computer". It sounds familiar though and as I've used many generations of Ubuntu including 14, which appears to be what you are using, and even 15.04 beta, it seems likely I have seen that generation of file manager. – gyropyge Apr 8 '15 at 9:13
  • But wait. The "home" folder in "/" is larger than 200GB. It is 276.3 GB, actually larger than the partition! – Lemon Juice Apr 8 '15 at 9:14
  • In that case it may be that your installation is actually on the larger "/home" partition and that the root partition is busy doing something else. Not sure what. Obviously, its not busy being the root directory. For a new user, you sure find strange things to do with Ubuntu. May I recommend you try a default installation and have fun in other ways such as becoming hand with using it to scan windows drives for viruses, recovering data for the owners of those drives and maybe even learning to use WINE. You do that and your Windows friends let you install Ubuntu! – gyropyge Apr 8 '15 at 9:22
  • actually it is slightly large, the partition is 275.67 and the folder shows 276.3 – Lemon Juice Apr 8 '15 at 9:28
2

Click on the folder that is called "home" and then click on your username folder; the partition should be mounted and available here.

Open a terminal and type the following command to confirm this:

lsblk

You should see the partition listed here and it should have a mountpoint listed as well. If no mount point is listed, you need to edit /etc/fstab to include the partition to be mounted when you boot at /home/<your_username>.

| improve this answer | |
  • actually, i see it's already listed as mounted at /home in your screenshot – mchid Apr 8 '15 at 8:17
  • how can I access "/home" ? In terminal if I type cd /home am I accessing the partition or home folder? – Lemon Juice Apr 8 '15 at 9:06
  • @JustCause They are one in the same kind of because the /home folder is where the partition is. All the contents of /home are stored on the home partition so all the contents of the partition are in /home. "/home" is the "mount point" of that partition (that is where the partition is mounted at). Your main partition is mounted at "/" . – mchid Apr 8 '15 at 9:08
  • OK, So linux is showing partitions as folders.... In windows I can see them separately. Hope I don't have to re-install everything.. – Lemon Juice Apr 8 '15 at 9:12
  • 1
    Regarding your size discrepancy, you're most likely looking at a GB vs. GiB issue. – Rod Smith Apr 8 '15 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.