sometime back - a month I think - when trying to install Libreoffice 3.4 (not from Ubuntu repository), without uninstalling Libre office 3.3, I installed it, and it was successful too.

But felt that it was still booting to 3.3, so I uninstalled through synaptic, and then installed Libreoffice 3.4. It was successful too, and i have all the latest features.

But, i am getting this message every time I open Libreoffice - word, calc or anything ....

in a pop up box :

LibreOffice 3.4

Error loading BASIC of document file:///home/office/.libreoffice/3/user/basic/dialog.xlc/: General Error. General input/output error

Can anyone suggest how to solve this..

2 Answers 2


IMHO there are two possible reasons:

  • dialog.xlc is missing;
  • dialog.xlc contains paths that are invalid after the removal of 3.3.

So, you should check first if the file is at its place:

$ ls -la /home/office/.libreoffice/3/user/basic/dialog.xlc

If it's there, open it with your preferred text editor (gedit, for example), and check the content for invalid paths.

If there's no dialog.xlc at that place, i would recommend searching for the default dialog.xlc on your system using:

$ locate dialog.xlc

and copy it into /home/office/.libreoffice/3/user/basic/.

  • Now it is solved: Sep 13, 2011 at 2:07
  • @sivakumarbharadhwaj: great, nice to hear. If you found an answer helpful, feel free to accept it :)
    – tohuwawohu
    Oct 20, 2011 at 8:17

Since you updated to 3.4 without removing 3.3, then had suspicions about it and removed 3.3. Did you remove Libre Office 3.4 at the same time as removing 3.3 and do a fresh install?

If not, I would recommend this, as well as installing from the PPA: sudo add-apt-repository ppa:libreoffice/ppa

I find PPA's easier than the actual site.

  • now it is solved : I opened the script.xlc (in the /home/office/.libreoffice/3/user/basic/ folder - using GEDIT. deleted all the contents, and saved the same as 'dialog.xlc'. That's all. Now when I open it does not show anything. BUT, what could have created this problem. Sep 13, 2011 at 2:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.