2

I'm hoping I can get some help with problems I've been having with sound in Ubuntu 14.04. I work a lot with audio recordings, and noticed difficulties when I started trying to record and annotate audio files in Ubuntu rather than Windows. I use Praat (phonetics software) for much of my work, and the program will crash my system when attempting to record in my Ubuntu install. I also use Audacity, and have noticed that most of the selections for playback and recording devices are not functional (I will be unable to record and/or unable to listen). I've also noticed that when I play around with the input/output device selections in Audacity, it will often cause there to be no sound available in system at all ... only a reboot will return sound to normal, and even then, it doesn't necessarily work immediately. For example, I recently used Audacity, played around with the device selection, and then had no system sound. Upon reboot, I still had no sound until I attempted a sound test of my analogue audio output, and then sound returned. Only analogue output will play sounds during an audio test. I would really like to better understand how audio is set up in Ubuntu, so I can hopefully use Linux for working with audio files. A list of my audio devices (aplay -l) is below, but please let me know what other system information is needed for help with this issue.

**** List of PLAYBACK Hardware Devices ****

card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog] Subdevices: 1/1 Subdevice #0: subdevice #0

card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital] Subdevices: 1/1 Subdevice #0: subdevice #0

card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0

  • you have alsa and pulseaudio. lookup pulseaudio to get a better understanding. pulseaudio is probably responsible for the audio completely going out on you. also, alsamixer is a command-line tool that can help sometimes. F6 will allow you to choose the device or audiocard. If you install alsamixer, run alsamixer from a terminal and DISABLE the auto mute option as it is enabled by default. Finally see this post on how to enable playback of the microphone input (be sure to have volume down or you'll get feedback) askubuntu.com/questions/123798/… – mchid Apr 8 '15 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.