From time to time I experience a very strange bug: Fonts broken

Fonts are broken not only in Firefox, but in the whole KDE environment. What can I do to fix it?


Installed Kubuntu from scratch and got this bug on the second day of using it. But now it affects only Firefox.


Well, it's not only in Firefox =)

  • 1
    Please edit your question to help us help you by providing more information. What have you tried doing to diagnose the problem? Have you tried running a RAM test? Checked SMART status on your drive(s)? Tried different video drivers? Anything you can tell us might be helpful. Thank you.
    – Elder Geek
    Apr 10, 2015 at 0:09
  • I can see it sometime on my 14.04.2 Ubuntu Gnome. Restarting the application fixes it. It happens (here) only for automatically started applications (i.e, an xterm showing a log for example). I suspect it's a timing issue with some daemon/dbus or similia which is not ready when the application starts.
    – Rmano
    Apr 10, 2015 at 8:26
  • System Settings >> Appearance >> Fonts Use anti-aliasing : Enabled click "Configure" check "Use sub-pixel rendering" and set it to RGB set "Hinting style" to Slight click "Ok" also "Force fonts DPI" set to 96 DPI Apr 16, 2015 at 14:19

5 Answers 5


Based on the information available in your question this can be a very broad range of things. I am going to list the ones that come to mind!

  1. You have selected a custom system font file that does not adhere to standards. Solution: revert to the default system font or find another without bugs.
  2. The font file is corrupt. This is not likely since you say it occurs from time to time. Solution: Replace it with an original fetched online. Rebuild font caches.
  3. There is a version conflict in the chain of libraries that are responsible for rendering your fonts. Solution: sudo update; sudo upgrade; sudo reboot; usually does the trick. Also if you have a lot of PPAs installed, I would disable them together with software installed from them temporarily to see if the problem goes away.
  4. One of the font rendering libraries has a bug. This could manifest itself as some glyphs not being rendered properly like in your screen-shot. Solution: Reinstall font rendering packages.
  5. The font rendering library's cache is corrupt. Font rendering is an expensive/slow operation and it is customary to use caches of rendered bitmaps that are dynamically managed at run-time to speed this up. Should the memory or disk-space required for this cache not have sufficient security privileges, run out space, become corrupted due to hardware faults then this would make font rendering look ugly. Solution: Rebuild font caches with this: sudo fc-cache -srv; fc-cache -rv
  6. Hardware accelerated font rendering will rely on both the GPU and its driver. The GPU driver may have a bug or you are having hardware problems with your GPU that manifest themselves as errors in font rendering. Typically GPUs will start malfunctioning "a little" when they are under stress, overheat or in some cases when they don't receive enough power from the PSU. Solution: make sure your system is not overheating. Make sure your PSU is scaled to handle your GPU. There are utilities that can help you stress-test your GPU to see if this produces your problem.
  7. Memory chips have faults that manifest as memory corruptions. If this is the case you may also experience instability. If a memory chip gets just one bit wrong every 4 days this can manifest itself as really hard to track errors. Solution: run memtest86 or similar memory testing tools to verify that your chips are fine.
  8. Individual applications may have bugs that manifest themselves like your screen-shot. Especially applications that are text and font intense such as web-browsers. I have seen this myself in Firefox. At one time all letters were exchanged for small filled boxes. Solution: restart app or system if it happens seldom. Update software version if it happens often.
  9. Firmware bugs is a reality, especially in low end hardware. Also bugs in firmware are often masked over in the WINDOWS drivers. For Linux users this means we get to keep the firmware bugs for free. Solution: If you got your computer for cheaps, or it is from a vendor not known for it's focus on stability/Linux support then maybe you should start saving for a new system.

Hope at least some of this was of use. I really had a great time writing it!


Try This before shaking ur computers Nervous system!!

To get KDE to display GTK apps well, you really need the ~/.gtkrc-2.0-kde4 theming that kubuntu-default-settings adds. Installing this will likely change your bootup logo to Kubuntu's though, so expect that. (You will obviously need kcm-gtk as well.)

You get all those packages when you install Kubuntu, but if you're just trying to install minimum-level KDE packages you'll have to fix it yourself.

Whenever you change font settings in KDE, it first saves the changes in the normal KDE settings file ~/.kde/share/config/kdeglobals that all KDE and KDE settings-aware programs read, and then also saves basic font settings (autoaliasing, hinting etc) in ~/.fonts.conf, for apps that don't have good KDE integration. What I guess is happening here is that the .fonts.conf settings transfer to your GNOME session. So, delete or rename it.


$ mv ~/.fonts.conf ~/.fonts.conf.bak

Nothing hard to fix this problem. There might be some upgrades failed to install or failed on half way progress. So you might want to upgrade your KDE or install it again to fix this problem. It happened to me when I used to upgrade font packages with kde file manager.


kUBUNTU 16.04.

Same problem, when i disconnect a monitor and reconnect again or when i change to shell(CTRL+ALT+F1) and go back to graphical interface (CTRL+ALT+F7).

Safe way.

1-Close all gtk applications.

2-Go to systemsettings --> Applications Style --> Style GNOME(GTK) ---> Change font size or change font to any different of default(Noto Sans), use this configuration until next reboot.

A dangerous way.

Another way is disable/enable the default(Noto Sans) font, but i tried this and broke everything was difficult restore to default configuration.


Normally, this might just be a problem of the original font file. You can re-download the font family from this direct link:


and then from there just re-install the entire font family. This shouldn't take more than 2 minutes combined. If this still doesn't work, leave a message in the comments

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.