0

I know you might want to mark this as an "duplicate" but it's not. All the answers on similar questions are either outdated or don't really include dependencies installation. dist-upgrade didn't help either.

sudo apt-get install codelite wxcrafter

gives me following errors:

    The following packages have unmet dependencies:
 codelite : Depends: libglib2.0-0 (>= 2.41.1) but 2.40.2-0ubuntu1 is to be installed
            Depends: libhunspell-1.3-0 (>= 1.3.3) but 1.3.2-6ubuntu2 is to be installed
            Depends: xterm
            Depends: libedit-dev but it is not going to be installed
 libjbig0 : Breaks: libjbig0:i386 (!= 2.0-2ubuntu4.1) but 2.0-2ubuntu1 is to be installed
 libjbig0:i386 : Breaks: libjbig0 (!= 2.0-2ubuntu1) but 2.0-2ubuntu4.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I'm looking for links to dependencies or any other solution. Thanks

EDIT:

I tried sudo apt-get -f install and it reported some broken packages (libjbig0 and libjbig0:i386) so I did force-remove them and now

sudo apt-get install codelite wxcrafter

gives me following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 codelite : Depends: libglib2.0-0 (>= 2.41.1) but 2.40.2-0ubuntu1 is to be installed
            Depends: libhunspell-1.3-0 (>= 1.3.3) but 1.3.2-6ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

I tried finding those "held broken packages" but without success.

sudo apt-get -f install

gives me:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

"0 not upgraded" - that looks fine, right?

  • Did you try to obvious solution and run: apt-get -f install ? – Eran Apr 7 '15 at 5:29
  • @Eran I did and it reported broken packages, so I removed them but problem persists - details in the question. – curusarn Apr 7 '15 at 19:16
  • Which Ubuntu version are you using? I can't see this info here. Are you using our repository ( the one from codelite.org ) – Eran Apr 8 '15 at 14:42
  • @Eran I use Linux Mint 17.1 which is based on Ubuntu 14.04 so it should have all Ubuntu's repos. – curusarn Apr 8 '15 at 20:35
0

I needed to add trusty repository instead of utopic one.
To install codelite follow instructions on codelite official installation page
except for:
sudo apt-add-repository 'deb http://repos.codelite.org/ubuntu/ trusty universe'

run this instead:
sudo apt-add-repository 'deb http://repos.codelite.org/ubuntu/ utopic universe'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.