Over the past 2-3 months I have progressively lost the ability to connect to an Outlook Web Access e-mail server (at one of the institutions I work for) from any computer running Ubuntu. At the same time connecting to the same server from computers running Windows works fine. I can't figure out what is going on, and the system administrator, though friendly, has limited time for Linux-related problems. Can anyone suggest any ideas?

More information:

  • The server name that I typically type in is vefpostur.bifrost.is, which gets translated into cloudowa.bifrost.is/owa.

  • I get a standard failure notice: "Server not found. Firefox can't find the server at cloudowa.bifrost.is." or in Chromium: "The server at cloudowa.bifrost.is can't be found, because the DNS lookup failed."

  • The problem is intermittent. Sometimes I can connect. But over time, and this is strange, the failure rate has increased and now it fails almost all the time.
  • I can ping the server successfully even when it fails.
  • My system administrator suggested switching to Chromium. I did, and at first it was able to connect, but quickly started to fail intermittently as well and now fails almost all the time.
  • All the machines I'm using run 14.04.
  • I've already tried deleting all cookies, etc. multiple times in both browsers.
  • I installed Firefox under Wine. I get the same problem. I didn't try Chrome.
  • I've connected via VPN. Same problem.
  • If I boot into Windows onto the very same machine, no problem -- I can connect every time.

I have googled around and found some reports of similar problems, though nothing quite exactly the same. The lack of similar reports and the behavior so far leads me to believe that the problem is on the e-mail server, not on any of my computers. But the only hypothesis that would seem to fit the facts is that the server is somehow hostile to requests from browsers running under Ubuntu and that this hostility increases with time -- which seems far-fetched.

Any ideas? Thanks in advance.

  • I had a similar problem against an Office365 server. Magically solved by reducing MTU on the interface from 1500 to 1400, ifconfig eth0 MTU 1400. Don't ask me why, seems voodoo.
    – Rmano
    Apr 6, 2015 at 7:42


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.