I was previously running 10.10 on my Acer Aspire laptop. It has Intel GMA 4500M integrated graphics and worked just fine. Great display, sharp, crisp, etc.

I decided to do a fresh install of 11.10 Oneiric and now am having problems. Originally I was getting the dreaded blank screen where the brightness was turned almost completely off. Some searching pulled up several easy fixes (editing GRUB).

Right now I am still having one issue. The screen resolution is stuck at a max of 1024x768 giving me a distorted screen.

Is there any way to fix this issue? I've Googled, searched Ask Ubuntu and also spent time on the forums looking for a solution. Thus far, nothing. Apparently, was and still is a concern in Natty?

Any help would be greatly appreciated.

  • I do have the Intel drivers installed, I also verified no other video drivers like ATI or nVidia were installed either. Sep 8, 2011 at 17:18

5 Answers 5


I have an Intel GMA 4500. I Googled for answers but nothing seemed to solve my problem.

Finally I came across this that says for acpi_osi=Linux, the brightness meter works in reverse, which was why my display started with a blank screen i.e. since it is reverse, max brightness = blank screen.

Following are a few interesting notes from the link:

  1. Without i915.modeset=0 the backlight does appear to start in the off position. Hitting Fn-brighter once turns it back on. On my keyboard, brighter is Fn-left-arrow and dimmer is Fn-right-arrow, which is different than I usually see.

  2. Starting with kernel modesetting gets me a graphical console that works fine until X tries to start.

  3. X won't start with kernel modesetting, either automatically or from runlevel 3. X -configure fails. With nomodeset 1024x768 is the only available resolution once logged in to a session. Of note, kdm comes up at the correct resolution with nomodeset but once the X session starts it falls back to 1024x768.

  4. acpi_osi=Linux is required for the back light keys to function. I see no lasting benefit to having turned it on and off as described in Comment #18 - still doesn't work with it off here.

  5. Same symptoms booting from the F15 DVD. nomodeset option works at reduced resolution, black screen with default graphical installer.

So if your display starts with a blank screen, try decreasing the brightness to check if the screen appears. My display works fine now, but in reverse.


Problem solved. Hope it helps someone out there!


  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Peachy
    Nov 11, 2012 at 11:09

Actually it works with the i915 driver and modesetting activated but there is a little trick to do. The black screen is only due to the fact that for some reason, the backlight is switched off. I've written the solution here it's in French but you may Google translate it.

Basically, the black screen is just a side effect but the it boots well, you can see that it is working if you use a torch light and point it to the screen. To switch on the screen you you have to

sudo setpci -s 00:02.0 F4.B=00 

Either by ssh or blindly with a tty and it magically switch on the screen. You have to modify /etc/rc.local to make it permanent at startup. The problem arise when you wake up from sleep as well, so you have to create and edit the file /etc/pm/sleep.d/10_screen_sleepand copy this :

# Switch the backlight on after woke up from sleep

case "$1" in
        sudo setpci -s 00:02.0 F4.B=00

By doing so, you will be able to use the driver Intel AND a high resolution.

Hope it helped.


Also in http://www.fedoraforum.org/forum/showthread.php?t=247355

Re: [Acer Aspire 3820T] Fedora 13 brightness issue Before deciding to google the issue (which led me here), I've randomly discovered another solution - brightness value set in sysfs (or just "set") will be applied on reboot, so if after boot "/sys/class/backlight/acpi_video0/brightness" shows 0 out of 9, setting it to 9 (via "echo" or keys) and just rebooting sets max brightness right from the BIOS screens and grub (which are also dim with 0). Guess the same effect should also apply to suspend-to-disk (basically the same reboot) and suspend-to-ram, but I haven't tested it.

Not that it's in any way better than setting brightness on the fly, which works for me with "acpi_backlight=Linux" added to cmdline (thanks!), still I thought I'd mention that in case that acpi setting won't work for someone (possibly with another laptop model or kernel).


Running Mint 11 on Acer Aspire 5734Z w/ Intel GMA 4500m

Originally when trying to install Mint from a live CD I was getting a blacked out screen. The video was there, but I could barely see it. I used “nomodeset” in grub, installed the OS and ended up with the same issue as described above, brightness level was right and video was visible but resolution was distorted and stuck at 1024x768. Changing the grub.cfg to acpi_osi=Linux (as mentioned above ~thank you!) instead of “nomodeset” fixed my resolution and gave me control of my brightness levels, but every reboot required adjusting the brightness level.

I found this fix for the brightness level reboot issue....

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/752165 (Post #9)

When I added the line of script to the /etc/rc.local file as suggested and rebooted my system there was no need to adjust my brightness settings.. it worked! :) Or it worked until my system went into screensaver/standby mode! Coming out of standby I still had to manually adjust my brightness settings.

Now.. to figure out how to fix the standby issue without taking the easy way out and simply adjusting my screensaver power settings!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .