0

I installed Ubuntu 14.04 alongside Windows 7 recently. On booting to Ubuntu, I have a problem with connecting to wireless internet. The wired LAN is working properly. The Broadcom Wireless Adapter has a driver installed (Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source).

Mostly, the WPA2 secured wireless connection I normally use on Windows 7 (and which is working on Windows fine right now) is just not detected by Ubuntu, whereas it detects other wireless networks in range. Rarely, the connection is detected (after trying to connect to hidden networks).

Most of the times, no connection can be established and the wireless just doesn't connect. Sometimes, a connection is established (computer icon is displayed), but I cannot browse the internet in any browser, which cannot open any page. I have used wireless internet on Ubuntu 10.4 before, but after installing 14.4, it has just not worked even once.

Is there a problem with the wireless network's configuration (IP address, DNS etc..)?

I'd appreciate any help in this issue. Thanks!

According to your suggestion, I have run the wireless_script in two scenarios: 1. My wireless network not detected: Here, the wired LAN (ethernet) is connected and working, in fact that is how I am accessing the net right now. The wireless detects other networks in range, but not my own which has the ssid Joshi. I use the same adsl modem to access both broadband and wireless. I've tried switching it on and off a number of times, but my network is not detected. I've pasted the contents of wireless_info.txt generated after running the wireless_script in this scenario on http://paste.ubuntu.com/10748052/

  1. My wireless network can be detected as hidden network, a connection is established, but there is no internet access: Here I try to connect to any hidden networks, and choosing my connection (ssid: Joshi) which I've created with the password. Here, the network is detected, and a wireless connection is established. But I cannot browse the internet, no page can be opened in Firefox. The contents of wireless-info.txt generated on running the script in this case are pasted at http://paste.ubuntu.com/10748062/

I'm also providing details of my wireless connection when connected on Windows 7:

Connection-specific DNS Suffix: local.lan Description: Broadcom 802.11b/g WLAN Physical Address: ‎90-4C-E5-4C-33-D6 DHCP Enabled: Yes IPv4 Address: 192.168.1.11 IPv4 Subnet Mask: 255.255.255.0 Lease Obtained: 03 April 2015 19:05:48 Lease Expires: 04 April 2015 07:05:48 IPv4 Default Gateway: 192.168.1.1 IPv4 DHCP Server: 192.168.1.1 IPv4 DNS Server: 192.168.1.1 IPv4 WINS Server: NetBIOS over Tcpip Enabled: Yes Link-local IPv6 Address: fe80::494e:fe6:8881:ee8c%10 IPv6 Default Gateway: fe80::226:15ff:fe51:896e%10 IPv6 DNS Server:

Hope this info is useful.

  • Please check out this question. – mikewhatever Apr 5 '15 at 17:57
  • Thanks for the reference. I've uploaded information about my wireless connection generated through wireless_script as suggested by you in the above post. Is thatany help to diagnose the problem? – Omkar Joshi Apr 6 '15 at 11:11
0

I believe you have the incorrect driver for your device. Please hook up the ethernet temporarily, open a terminal and do:

sudo apt-get purge bcmwl-kernel-source
sudo apt-get install firmware-b43-installer

Detach the ethernet, reboot and let us hear the result.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.