1

I wanted to password protect individual folders on my system, so I installed Cryptkeeper by following the first answer here: How to encrypt individual folders?. However, the icon of Cryptkeeper did not appear on the top right, so I followed the first comment, opened a terminal and executed

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

Nothing happened, so I also did

unity -- replace

There was some strange behaviour on my monitor, some of the windows stopped functioning properly and there were many error messages in the terminal. Apparently there were still some processes going on because it did not return a prompt. I waited 10 or 20 minutes but then pressed CTRL+C and restarted the system.

When I tried to log in, the screen became black for a second, there was the usual sound but then the log in screen appeared again, although I entered the correct password (it did not say it was not correct). So, now I cannot log in and I use the guest account to write this.

I tried CTRL+ALT+F1, the screen becomes black with a blinking white space in the upper left corner but I cannot type anything. (I wanted to execute sudo chown -R $USER:$USER $HOME). CTRL+ALT+F2 produces the same result. I also tried to add a new user with sudo adduser newuser, but I got sudo: unable to change to sudoers gid: Operation not permitted followed by sudo: setresuid() [0, 0, 0] -> [119, -1, -1]: Operation not permitted.

Does anyone know a solution? I need my account with all the data and personal setting but right now I don't have the time to reinstall Ubuntu and do everything again.

3
1

I figured it out. From the guest account I couldn't create a new account using the terminal but, surprisingly, it works from the GUI (System Settings > User Accounts). I created a new administrator account. Then opened a terminal from there and typed

su <username>

Here <username> is the user account that I couldn't log in to. After entering my password, I was able to mount my data and transfer them. Not only that but after deleting the .Xauthority file I could log in to my account normally like before. So, problem solved. :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.